3

Sharepoint 2010 RTM

In central admin - I attempt to create a new App (IIS website) the pop up screen accepts my input and goes to work, but eventually it times out and displays a message that Internet explorer can't display the page.

The IIS site is created on the primary Sharepoint 2010 box, but the secondary WFE (web front end) does not get it's site created.

I've looked at the windows event logs and the 14 hive logs and nothing has struck out.

Any thoughts on what to check next?

Is there a timer job that does the creation of sites on the other boxes?

2
  • did you find any solution to this problem?
    – user4995
    Sep 26, 2011 at 18:48
  • This sounds permissions related to me. Does your configuration admin account have admin access to the new box?
    – webdes03
    Sep 26, 2011 at 19:10

1 Answer 1

4

There is a strong possibility that the application pool for central admin timed out before the application was created on the second node. To fix this:

Delete the web application that did not provision on all WFE's On the server hosting Central Admin, open IIS manager. In the tree view, expand the server name and click on Application Pools. Locate the SharePoint Central Administration v4 application pool. Right click on it and choose Advanced Settings. In the Process Model section, set the Shutdown Time Limit to a greater value (default is 90 which is often to little). Set it to 150 and try again Recycle the app pool

(try to allocate more resources if possible so it doesn't happen in the future)

3
  • Scott, sorry for the late reply - I believe this is exactly what happened - I increased the timeout value across the farm and the problems went away.
    – Jack
    Feb 25, 2013 at 19:54
  • This fixed my problem. Before increasing the length, it only created the content db, and a single folder "_forms" for the IIS website. Mar 24, 2015 at 17:38
  • I had same problem and your tips save me!
    – Mark L
    Oct 26, 2015 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.