0

Hello I have a problem with the top navigation.

I have created a sub-site from a site collection. now, the sub-site has a different master page that is similar to the master page in the site collection. the site has a navigation menu and when I create the sub-site it inherits it's top navigation menu. Now I want a different navigation menu and I don't know how to configure it. when I create the current navigation for the sub-site it still showing me the navigation from the top site.

Thank you for your help. Yotam.

1

Okay Finally found a solution:

this is how the navigation bar looks inside the master page:

<asp:ContentPlaceHolder id="PlaceHolderTopNavBar" runat="server">
    <asp:SiteMapDataSource
            ShowStartingNode="False"
            SiteMapProvider="SPNavigationProvider"
            id="topSiteMap"
            runat="server"
            StartingNodeUrl="sid:1002"/>
    <SharePoint:AspMenu
        ID="TopNavigationMenu"
        Runat="server"
        CssClass ="mega-menu"
        EnableViewState="false"
        DataSourceID="topSiteMap"
        AccessKey="<%$Resources:wss,navigation_accesskey%>"
        UseSimpleRendering="true"
        UseSeparateCss="false"
        Orientation="Horizontal"
        StaticDisplayLevels="2"
        AdjustForShowStartingNode="false"
        MaximumDynamicDisplayLevels="2"
        SkipLinkText=""

        />
</asp:ContentPlaceHolder>

all I needed was to change in the "SiteMapProvider" to value shown above. hope it helps someone!

0

If I understood you correctly you want to show only subsite menu and not to show parent site menu? If so, on creating subsite there is an option at the bottom of the page, where it states Navigation inharitance: Use the top link bar from the parent site? then you can choose Yes or No.

  • I tried that it didn't work. I think it is related to settings in my sub site master page. – Yotam Bloom Aug 17 '15 at 10:13
  • I never edited navigation in master page. open master page in SP designer in advanced mode and try to see for it. – Danilo Aug 17 '15 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.