1

The "Add a web part" function is not appearing in my list. I took the proper steps (List tab --> default new webpart) to go to the section but it won't display still. I am the site collection admin as well, I also did it before in the past but I cannot view the web part in my past sites either... This is the section I am trying to access

This is what I am seeing -->enter image description here

  • the image is what I am trying to access but cant – Raymound Aug 13 '15 at 17:47
  • 1
    What tabs on the Ribbon can you see? Can you provide a screenshot of what you're seeing? – clk Aug 13 '15 at 22:28
  • please see the updated post, the 2nd image is what I am seeing. – Raymound Aug 14 '15 at 13:32
  • If you go to a page (not the list page) such as the default.aspx in the same site as the list, can you open the page in edit mode? And if so, can you see the insert tab? – clk Aug 14 '15 at 15:50
  • only the "Browse" and "Page" tab appear. when I click edit page, it just refreshing.. I feel like im missing something – Raymound Aug 14 '15 at 15:57
0

Not sure but have you edited the page. Once the page is in edit mode then you would be able to see the Add a Web Part section.

  • I also tried clicking on the “Gear” icon and “edit page” which didn’t work either. is there a setting I am missing – Raymound Aug 14 '15 at 14:02
0

You don't add web parts to a list, you add them to a page. A good thing to keep in mind is that lists and libraries are where you store and manage your data, pages and web parts are for presenting it out.

To add a web part, go to the page you want to add the web part to, then edit the page (you can do this using the Page tab in the ribbon if it's there, or the gear cog to the top right of the page if not).

One recommendation I would make is to be careful about which pages you edit. I generally suggest to people to avoid editing the pages which are created when you add a list or library. These are the pages you see when you go go the list or library in your left hand navigation. In fact, in a SharePoint context I tell people to forget that they are pages at all, just think of them as going to your list or library, and again that is for storing and managing your data, not for presenting it. There are times when you do need to edit these pages, but if you don't know what you're doing it's easy to do more harm than good.

I would recommend instead only editing your site's home page, or adding new pages to it (again using the gear cog to the top right) and editing those. Then you can add/edit/delete all the web parts you want in relative safety.

  • I tried that but it didn't do anything just refreshed my page... I wonder if it has something to do with my settings... – Raymound Aug 14 '15 at 14:06
  • This is wrong. When you navigate to a list, all you get is a page with the list view web part added. So yes, technically it is a page. Changing the page does nothing to the list. – Akhoy Aug 14 '15 at 16:00
  • Yes, it is just a page with a web part on it, but I've lost count of how many times someone has edited one of those pages and deleted the web part. And it's not very intuitive to recreate. – Steven Mulkerrins Aug 14 '15 at 16:05
0

It sounds like others have had problems with editing pages in SharePoint 2013 and the page just refreshes instead of opening in edit mode and web part properties can't be changed. This is related to Internet Explorer 11 not running in compatibility mode. Read this article and the comment from Waseem Khan in the comments section: http://wendy-neal.com/2014/06/unable-to-modify-sharepoint-2013-web-part-properties/

To run the site in compatibility mode in IE, do the following:

  • Press ALT + T when viewing your SharePoint page
  • Click Compatibility View Settings in the menu that appears
  • Click Add to add the current SharePoint site to your list of compatibility view pages
  • Click Close

Also, you can try using Chrome to see if it truly is an IE issue, as opposed to a setting or permissions issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.