I am using WSS 3.0

When I hover over an item (i.e document) and click the down arrow, the drop down menu appears (ie. View Properties, Edit Properties, Delete, etc.) but actions only work in Chrome, not in IE 8 (neither in normal nor in compatibility mode).

If I click delete to remove an item, the menu disappears and nothing happens. The item is never deleted and no error is ever thrown (I have enabled debugging in IE but no error thrown, it simply does NOTHING in IE).

EDIT: @AlexPoint, Hi, thanks, hopefully these answers will help:

AlexPoint: Please tell us: (1) If the issue has arised after an change (like patching, migrating, etc.) or if you just setup a new farm. (2) If the issue occurs with other client machines (3) If you have any customizations applied that might effect your site. –

1) Yesturday I was handed a brand new server 2003 box built and installed this week.

My collegue who installed server 2003 selected the out-the-box installation of WSS2.

Without making any changes to any part of sharepoint, I noticed in internet explorer (as I have script errors enabled) when I attempted to click on a context menu item a javascript error would appear (undefined is null).

I checked in Google Chrome and the context menu wouldnt even appear. Therefore I assumed that this is due to wss2 being developed for IE6 and that an upgrade would resolve this Bug with all modern browsers.

I downloaded wss3 from microsoft, installed, ran prescan (no errors) and ran the config leaving everything default - success, it was upgraded and actually looks alot better, we even have a search bar now!

I tried to install all the wss3 service packs, but the installation I downloaded from microsoft must have included these as it said they were already installed.

Now that I am on wss3 I start to delete "Sample Project" or "Sample Document" etc.again, but this time when I hover over the item, click the arrow which brings up the drop down (with "view properties", "edit properties", "delete" etc.etc.") but whenever I click on any of these options, IE7/IE8/compatmode does nothing. I tested in Chrome and since upgrading to wss3 the menu now actually appears and the buttons even work! Unfortunatly everyone uses Internet Explorer 8.

Half of SharePoint has these context menus, so again this means no one can use SharePoint yet. I have opened up "Developer Tools" in IE and added breakpoints to various functions called by the onMenuClick event of the context menu items, but the breakpoints are never hit or captured and I gave up before my stress levels became irreversible.

2) I have tested on 5, yes 5 lol! systems in Internet explorer 8, they all have the same problem. Please remember that this is out the box installation, no changes made, simple upgrade to wss3, still no changes made to the config, look and feel, or to any of the asp scripts.

3) no customizations - this really is a "Fresh" installation.

Anyone who helps me fix this ; I love you long time

EDIT: Whilst Google Chrome actually works, it throws an error which isn't thrown in IE, but what I believe is causing the problems in IE.

Uncaught TypeError: Object #<HTMLTableCellElement> has no method 'click'


  • 1
    Please tell us: (1) If the issue has arised after an change (like patching, migrating, etc.) or if you just setup a new farm. (2) If the issue occurs with other client machines (3) If you have any customizations applied that might effect your site.
    – AlexPoint
    Commented Jun 28, 2011 at 12:52
  • @AlexPoint: Please see updated question with answers to your questions.
    – Chris
    Commented Jun 28, 2011 at 14:13
  • Also, where there is a tool bar that contains "New, Upload, Actions, Settings" the buttons work, but if I click the arrow to the right of the button, which makes a different drop down appear with extended options, again I click on the item and it does nothing. If I go to "New" > "New Folder" and click it, it closes the sub menu but does Nothing. T_T
    – Chris
    Commented Jun 28, 2011 at 14:20

4 Answers 4


I had a user with the same issue. He appeared to be the only user with the issue. When he accessed from another PC it worked fine. using FireFox on his main pc worked fine also. Found that there was a DivX Add-in installed in IE -when I disabled that add-in everything started working fine.

He didn't use IE as his default browser, so I didn't bother trying to reinstall the DivX component.



I never heard about such an error and since you say there is no custom code and that is works with a different browser (Chrome) I cannot image that its truely a SharePoint Server error. There is just no possible configuration (or mis-configuration) that could cause the IE to fail while other are not.

If we say that SharePoint is not the root of the problem, we are left with the client and its brower(s). You said that you tried with five different machines and every one has got this issue.

This make me think that there might be general setting in IE that causes the menu not to open. With "general setting" I mean something like a group policy that is applied to all of your machines. It might be something you have not thought about yet, some little change to the default settings.

So, you might want to check the domain/machine/user/group policy thing in detail. Maybe you can convince your domain admin to run a test with a machine that has no policy at all!

If that won't bring any results check for plug-ins, add-in, etc. in your browser. Some ad-, script-, popup-, flash-blocking might cause some crazy side effects.

Good luck!

  • If I connect to SharePoint via localhost (on the server) I dont get these problems, anywhere else and I do, must be a domain thing but adding to trusted sites didnt help.
    – Chris
    Commented Jun 30, 2011 at 8:55
  • There you go! So the problem does not occur on the server? Does it work from other servers? Maybe it is a domain policy that is applied to clients/workstations but not to servers? That would narrow the possible policies. :)
    – AlexPoint
    Commented Jun 30, 2011 at 9:08
  • Yes your right, the server must have been fine all along. This is the first time I have ever attempted to work with SharePoint (other than as a restricted user) and I have to admit, these problems have confused me quite a lot - Not sure about the policies, I cocked up the install and am having problems reinstalling WSS 3.0 (one error after another :-( - as its a new system I might just reinstall the whole server next week and try again then, I have at least learnt a hell of a lot about the administration side of SharePoint.
    – Chris
    Commented Jun 30, 2011 at 11:06
  • Could not find stored procedure dbo.proc_getobjectbyclass (it looks like I never uninstalled the wss3.0 db properly?) downloaded the hotfix mentioned on the URL below (KB934790), and it gets further in the configuration process but bombs out with "The object with id b614c988-eab5-4fbd-8024-a9574ee2b199 does not exist in the configuration store" - not sure what to do now (I choose the install mode which allows me to upgrade the site manually once the v3 service is installed but it wont install :-(
    – Chris
    Commented Jun 30, 2011 at 11:18
  • blogs.technet.com/b/jks/archive/2009/03/04/…
    – Chris
    Commented Jun 30, 2011 at 11:18

Yes, I have the same problem with unclickable menus in Sharepoint sites and the reason was exactly in DivX installed. I have uninstalled it, as it did not work properly anyway. Now it works!

  • Yep, uninstalling Divx Plus Web Player fixed it for me.
    – user8123
    Commented Apr 30, 2012 at 18:46

I had a user with the same issue. I narrowed it down to being the NameCTRL Class Add-On in IE. PC has IE8 and I believe we run SharePoint 2007.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.