0

I just added a page viewer web part to my site page and entered the link to the URL I want displayed. Now, every time I go to that site page this message pops up on the bottom of my web browser enter image description here

The page viewer web part won't display until I click on "Show all content". If you don't click on it fast enough, the message disappears and you have to refresh the page to see it again.

4
  • 1
    that is expected if you are linking to http content on a https site like sharepoint online Aug 10, 2015 at 14:54
  • Did you try adding your url as a trusted site?
    – Marco
    Aug 10, 2015 at 14:56
  • Explain how to add as a trusted site please.
    – Andrew
    Aug 10, 2015 at 14:59
  • Internet Options -> Security tab -> trusted sites. Bellow you will see a button "Sites", click on it and add the url of your site in the displayed window
    – Marco
    Aug 10, 2015 at 15:07

1 Answer 1

1

Your site is most likely accessed via HTTPS:// , correct? If so, all links that display content on your site also need to be HTTPS.

So, if you site is: https://example.com ...and you attempt to load content from a different site (using a page viewer web part in your case) it ALSO needs to have the HTTPS:// protocol. So instead of this:

http://google.com

do this:

https://google.com

..to access your external content.

2
  • Correct. It is https://. I will give this a try.
    – Andrew
    Aug 10, 2015 at 15:10
  • If this answer helped you, could you please mark it as the answer? Thanks
    – Kolten
    Nov 25, 2015 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.