I have SharePoint hosted app which contains several elements like list, Pages and workflows. In AppManifest.xml, In permissions we have enabled "Allow the app to make app only calls to sharepoint" and also we have apponlysequence in Workflow to elevate the permissions and run for all users. After enable this option, during installing the workflow, we are getting Click here to trust. When Site collection administrator tried to trust the app, he is getting " you do not have access to trust the app". Eventhough he is an admin of the site and not able to trust the app. Please help me how to resolve this issue.

  • I got the same error. Disabling "Allow the app to make app only calls" seemed to do the trick. Not sure how. Weird... – Akhoy Aug 10 '15 at 13:53
  • Yeah. this is really weird. I've used AppOnlySequence activity in Workflow and in order to run the workflow for all users, we need to enable that option in Permission tab under appmanifest.xml. But without trusting the app, we're not able to perform app upgrade. – Balaji Aug 10 '15 at 14:01

I resolved the issue by upgrading the app using powershell with farm admin account. Farm admin account was able to trust the app and he able to upgrade the hosted app.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.