I have been handed a server that has a fresh installation of small business server 2003.

SharePoint has been installed, and it is a completely fresh copy (no changes made)

I know for a fact that everything was paid for so this isn't some dodgy copy.

When I try to click any option in any of the floating menu's in IE 8, the browser asks me if I want to debug .. Error: 'undefined' is null or not an object

for example, I got to Projects - and click on the sample project, then click delete on the floating menu that pops up and the error appears.

This is brand new, I cannot believe Microsoft products are annoying me on purpose again!

Has anyone come across this, is it an old problem with easy fix?

EDIT: OK.. So I upgraded to WSS3 and the site is looking alot better apart from the cross browser problems. However, whilst this error no longer appears, the problem effectivly still remains, if I hover over any item in any area of the portal in IE8 (compat mode or not) then click the arrow so that the drop down menu appears (with view properties, edit properties, etc. delete, etc. etc.) when I select any item at all, rather than a javascript error being thrown. IE 8 simply does sweet FA. I have tested in several browser and all but IE works, and no error is being thrown in any. WHAT THE FUCK MICROSOFT -- help me please. browser cache cleared, still doesnt work.

  • What version of SharePoint? Commented Jun 27, 2011 at 15:30
  • The version is WSS2.0
    – Chris
    Commented Jun 27, 2011 at 15:51
  • Is this all on one machine? Have you tried to connect from a different machine running IE8? Commented Jun 29, 2011 at 13:05
  • Must be a policy issue (still not resolved) because if I connect to it on local host (on the server) it worked fine, all other PC's have this problem. Problem is I have now cocked up the install and cannot reinstall wss3.0 :(
    – Chris
    Commented Jun 30, 2011 at 10:52

1 Answer 1


Have you tried to utilize a different browser (IE6/7) or comparability mode, and experienced the same result?

SBS 2003 shipped with WSS2.0, so I'm not sure if this is what you are running or you upgraded based on your comments. It was built with IE6 in mind, so its not surprising to see issues with later browsers. You can upgrade to WSS3.0, but it must be a side by side installation (don't ditch the 2.0 or you will lose your integration features with SBS). That may be the route to fix your compatibility issues.

If you are already running WSS3.0/SharePoint Server 2007 and you didn't do a side by side installation, your issue could be stemming from that (if your trying to access the built in pages with SBS integration). There is no way to reverse this installation type without an SBS backup restore or rebuild.

  • @Jesus: Hi, I tried in compatibility mode, same problem. I try in Google Chrome and the hover over doesnt appear so i cant even click the drop down menu
    – Chris
    Commented Jun 27, 2011 at 15:39
  • @Jesus: Hi, I believe it is WSS2.0 - are you able to provide me with any info/links on how I can go about upgrading to v3.0 Thanks!
    – Chris
    Commented Jun 27, 2011 at 15:52
  • I am going to upgrade wss2 to wss3 - microsoft.com/download/en/… ,, techrepublic.com/article/…
    – Chris
    Commented Jun 27, 2011 at 15:57
  • upgraded to wss3 and works fine. had a problem along the way (see sharepoint.stackexchange.com/questions/15285/…)
    – Chris
    Commented Jun 27, 2011 at 16:26
  • 1
    SBS can be tricky. Do you still have use of the company web (i.e. wss 2.0)? If not, you can do a re-install of the intranet via the SBS wizard and that should restore that. I'm guessing the error you are getting is SQL related, manaually removing the 3.0 databases should allow you to repair your installation. If you are using Windows Internal DB you can use the instructions in this article to connect to it: blogs.technet.com/b/gborger/archive/2009/02/27/… Commented Jun 30, 2011 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.