While trying to open an excel document stored in "Shared Documents" library, the excel application opens up with a login prompt, to which I passed the login credentials of the site. After which the excel shows an error

"Could not open 'http://sp2010//shared documents/Sales.xlsx'"

The same is the case for word documents too. I am running SharePoint 2010 server on windows 2008 R2. The same machine is used for development. MS Office 2010 Professional plus installed on the same machine (not activated). The browser version i am using is IE8.

After searching the net, I tried the following steps but nothing turned to solve the problem

  1. Enabled the "Desktop Experience" feature in windows server 2008

  2. Unchecked "Auto proxy detection" in IE settings.

  3. Added the site to trusted list in IE.

  4. In excel added the Sharepoint the URL 'http://sp2010/' under 'Trust Center' options.

  5. In excel unchecked all "protected view" options under 'Trust Center'.

  6. Tried applying the "" as proxy, didn't work and reverted it back.

I tried opening the 'Sales.xlsx' after downloading the file from "Shared Documents", which opened up without any issues.

Now I am completely out of options on what to do next to get this working.

Please help.

Update: I had disabled the server firewall but the problem still persisted. Thereafter I mapped a network drive to the following url 'http://sp2010' to which I was able to browse the location where the 'Sales.xlsx' was located. But opening file from this location too gave me the same error.

Update: Finally it seems like I had got the culprit behind this wired behavior. I am posting the steps that worked for me. It seems the temp contents in the 'OfficeFileCache' along with SharePoint workspace was the reason behind the issue.

9 Answers 9


I noticed that SharePoint Worksapce was running in the system tray which had the "Shared Documents" library synced, because of this there were some temp files out there in the following location


after terminating the Sharepoint workspace and clearing those temp files, I was able to open documents in Office client.

You can simply close all office application and navigate to the location above, shift del all files and try to access the files again, it worked like a charm for me

  • 2
    Sharepoint workspace wasn't running for me, but deleting the contents of the that folder still fixed the problem Apr 15, 2013 at 14:02
  • deleting the files in c:\Users\login_user_name\AppData\Local\Microsoft\Office\14.0\OfficeFileCache worked for me as well.
    – user24177
    Mar 5, 2014 at 21:01
  • Thank you AbrahamJP !! I've been suffering for so long and I tried so many things!
    – Deian
    Feb 25, 2015 at 19:17
  • I deleted the files, but still not working. This file was accessed by many users. Do I need to clear other users cache as well ? May 28, 2015 at 12:07
  • If multiple users/devs are using the same machine. You might have to clear other users cache as well. If that too doesn't work try running SysMon from Sysinternals to see for any file locks
    – AbrahamJP
    Jun 3, 2015 at 13:25

We had to open a case with Microsoft about this same issue. We literally tried every solution suggested in this thread and many others (IE settings, Office Trust Center settings, removing cache directories, etc, etc). It turned out that a pre-release version of Office was installed on the affected machines. The pre-release version (found in Control Panel -> Programs) was 14.0.4734.1000. Microsoft support told us that the pre-release version had issues integrating with SharePoint. Uninstalling the pre-release version and installing a release version solved it for us. I hope this prevents some weary soul from investing the hours we did into a bunch of nothing!!!

Here's the link for valid release versions of Office:



The only thing I can think of is that when opening a file from SharePoint directly, Word uses WebDAV to communicate with the server. If this protocol is disabled in the firewall for instance, Word would be unable to retrieve the contents of the file.

  • Yeah as you said I did disable the firewall too, but still the same. I was able to sucessfully map the url to my site sp2010 as a network drive under "My Computer" and was able to browse the same, but if I try to open documents from there, then again the same problem shows up. Anyway thanks for pointing out any chances with firewall.
    – AbrahamJP
    Jun 24, 2011 at 17:55
  • Another thing: In the web app's general settings (Central admin -> web apps, select web app, general settings in the ribbon), do you have client integration enabled?
    – Colin
    Jun 24, 2011 at 17:59
  • I did verify the option you had mentioned. The 'Client Integration' is enabled for the web app. thanks for that. I believe, I am almost near to the solution after clearing the 'OfficeFileCache'.
    – AbrahamJP
    Jun 24, 2011 at 18:25

Also make sure that Word has access to the network. I sumbled across this in a VM with no network support : in this case, even in local, word won't open the document after all this.


Installing secure store service and followed by installing excel service application and connecting web application to the excel service application will solve the above problem.

In order to open all office documents from SharePoint you need to do following steps:

  1. Internet Explorer --> Tools -->Internet Options -->Advanced tab -->click Restore defaults button -->Click "OK"

  2. Internet Explorer --> Tools -->Manage Add-ons --> disable NameCtrlClass, SharePoint Opening Documents control (controls by selecting currently loaded add-ins from left pane dropdown menu) controls

  3. Close and re-open the Internet explorer and check the documents functionality


for me only executing 2 lines of power-shell from http://blogs.technet.com/b/excel_services__powerpivot_for_sharepoint_support_blog/archive/2013/05/21/excel-services-the-workbook-cannot-be-opened.aspx fixed the issue

$w = Get-SPWebApplication –Identity http://tschauer

it was due to migrating WSS_content_XXX to another server. for me the new server was SQL server 2012 which i used the always-on listener name instead of actual servername.


The answer fro AbrahamJP worked for me just fine! Thanks man, was struggling with that issue for 2 days. My laptop turned off due to battery exhaustion, I think this is the reason of creation of those annoying temp files. Clearing OfficeFileCache fixed the issue.


Another possible reason, user entered a wrong password. Word showed the same error message like above. Try using others account that you know the password to open it first.


please check if your Microsoft office is not corrupt .because on my side it was corrupt and what i did is :

  1. reinstall the Microsoft office and it will be fine.
  2. restart the computer and re-open the share-point.
  3. click on the excel file and it will open

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.