0

The wf was working fine until i made few more changes and redeployed it again Below is the error i am receiving. I removed the changes and then again redeployed still same error.

 Error    1   Error occurred in deployment step 'Activate Features': Microsoft.Workflow.Client.ActivityNotFoundException: The activity named 'WorkflowXaml_ac17eed9_9bdc_4aaf_9a33_eb48d306d966' from scope '/SharePoint/default/d4e22c44-37d3-40da-b0a1-0d587c1dc4ac/dc67e687-00ba-4998-bc52-0c6fc4b2e24f' was not found. HTTP headers received from the server - ActivityId: b243fbbc-dab1-4a4e-a184-b25a13eba6ae. NodeId: ------. Scope: /SharePoint/default/d4e22c44-37d3-40da-b0a1-0d587c1dc4ac/dc67e687-00ba-4998-bc52-0c6fc4b2e24f. Client ActivityId : f350acf8-e195-4cd6-b

After digging in the ULS log I found some more information

    Microsoft.Workflow.Client.ActivityValidationException: Workflow XAML failed validation due to the following errors:
 The private implementation of activity '1: DynamicActivity' has the following validation error:   Variable 'System.Activities.Variable`
1[System.Collections.ObjectModel.Collection`1[System.String]]' cannot be used in an expression of type 'System.String', since it is of type
 'System.Collections.ObjectModel.Collection`1[System.String]' which is not compatible.  HTTP headers received from the server - ActivityId:

Any suggestions?

  • Hi! Do you have updates? I have the same problem – nvdev Aug 7 '15 at 9:29
0

I checked in the code and stripped down the workflow to just have a simple sequence with a log to history and tried deploying that, still had the same error.Which made me suspect that the problem must have been with the server or Visual studio itself. I did a server restart and viola!, it worked just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.