2

I cannot change my passphrase.

Here is my Powershell commands

PS C:\Users\myuser> $passphrase = ConvertTo-SecureString -String "Mypassphrase1" -asPlainText  -force
PS C:\Users\myuser> Set-SPPassPhrase -PassPhrase $passphrase -Confirm

cmdlet Set-SPPassPhrase at command pipeline position 1
Supply values for the following parameters:
ConfirmPassPhrase: *************

Confirm
Are you sure you want to perform this action?
Performing operation "Set-SPPassPhrase" on Target "SPPassPhrase".
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help
(default is "Y"):A
Set-SPPassPhrase : Error deploying administration application pool
credentials. Another deployment may be active. An object of the type
Microsoft.SharePoint.Administration.SPMasterPassphraseDeploymentJobDefinition
named "job-admin-passphrase-change" already exists under the parent
Microsoft.SharePoint.Administration.SPTimerService named "SPTimerV4".  Rename
your object or delete the existing object.
At line:1 char:1
+ Set-SPPassPhrase -PassPhrase $passphrase -Confirm
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidData: (Microsoft.Share...etSetPassPhrase:
   SPCmdletSetPassPhrase) [Set-SPPassPhrase], InvalidOperationException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletSetPassPhrase

I have tried to clean the cache as suggested in other posts. And after cleaning the cache I can apparently set the passphrase. But the job doesn't execute even if the timer service is running. Besides, If I try this code

PS C:\Users\myuser> $job = Get-sptimerjob job-admin-passphrase-change
PS C:\Users\myuser> $job

Name                 Schedule             Last Run
----                 --------             --------
job-admin-passphr...                      8/5/2015 6:11:22 AM

I see the job is still there. And if I try to reset the passphrase once again I get the initial error named "job-admin-passphrase-change" already exists under the parent .

Is there anything I could try?

1 Answer 1

0

I know this is a stupid answer, but I had this exact problem once before and I restarted the SharePoint Timer Service and reran the job, and the problem went away.

1
  • thanks, but I have already tried that
    – Gyonder
    Aug 5, 2015 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.