1

In my sharepoint discussion board app, if I create a thread and click on it like so:

enter image description here

It takes me to a list view for the question which looks like this:

enter image description here

But that's not very helpful. I want it to link me to the discussion thread:

enter image description here

I remember it linking to the thread before, I'm not sure why it's started doing this. Does anyone know where the setting to change this is?

Thanks in advance.

Edit:

Okay, so a little further along now. The question is how to turn this:

enter image description here

Into this:

enter image description here

I can't figure out where the setting to change "Show In" is. Now my discussion threads look right (the flat view) but I want the discussion board views to not have the same view.

1

So you can achieve this using changing the view of your Discussion board.

Path :

Your discussion board -> List Setting -> Views -> Threaded(Flat in online) -> check this option --Make this the default view -> Save.

  • Thanks for your response! I can't find this option though. Are you doing this in sharepoint designer or online? – Charles Clayton Aug 4 '15 at 21:02
  • Its available in online, check the ribbon using browser. – Pushpendra Aug 4 '15 at 21:06
  • Okay, so on my sharepoint there isn't an option for threaded, but "flat" view does essentially the same thing inside the discussions. I could create new flat view and make that the default view, but that screwed up all my other views. How can I make it the default view for only discussions, like in the example screenshot in the edit. – Charles Clayton Aug 4 '15 at 21:18
  • Ok..I checked on online site, yes the threaded view is not present and Flat view does the same. Now if you set the Flat view to be the default view your problem should be fixed. – Pushpendra Aug 5 '15 at 3:19
  • The problem with doing that is that by making flat view the default, you see flat view when you're looking at the overall view, not just in the reply threads. I fixed the problem by rolling back to a previously saved template, but I'm leaving the question open because I still want to know how you set two different default views: one for the discussion and one for the top level view. – Charles Clayton Aug 5 '15 at 3:57
1

I'm a bit late to the party, but I hope this helps someone as I just figured this one out. To get the two different default views that you are requesting in your edited question, you will need to go into SharePoint Designer. First, you need to go into the advanced settings for the list and enable editing of content types. Then, when you go into SharePoint Designer, you want to edit the AllItems and Flat views to change ReadOnly="TRUE" to ReadOnly="False in the <View> tags. Head back to SharePoint and modify the view. You should now be able to scroll down the modification screen until you reach the Folders options. Change the AllItems view to be shown only In the top-level folder and the Flat view to In folders of content type Discussion. It should now appear properly.

The general idea came from this site, which I quote here (minus the pictures as apparently I do not have high enough reputation to post them all):

How to implement it

Ensure content type management is enabled for the library. This is under Library Settings | Advanced Settings.

Create a view to use at the root (top-level) of the library, selecting the desired columns, sort order, etc. I’ve called mine ‘Library View’. The important steps here are to:

1 – Set this view as the default view

2 – Expand the Folders setting option and select ‘Show in this view: In the top-level folder’. Note: these options only become available once you have enabled management of content types in the library.

Now save the view and the library view settings should look similar to this:

Notice that Library View is designated to only show in Top-level and is set as the default view for the library.

Now create another view that you want to use to display documents when inside folders. Again create the view and setup the desired column, grouping, sort order etc. I’ve called mine ‘By Project’. Important steps here are:

1 – Set this view as the default view. Yes I agree this doesn’t seem right. You would expect this to replace the ‘Library View’ as the default view – but in combination with the ‘Folders: Show in’ option some unexpected magic happens! Read on.

2 – Expand the Folders setting option and select ‘Show in this view: In folders of content type [Folder]’

Now save the view and take a look at the view settings for the library.

SharePoint has allowed us to have 2 default views! The show in column tells us that the ‘Library View’ view is the default for the Top-level (or root) of the library and the ‘By Project’ view is the default when in any Folder.

That’s it – when you now navigate to the library you will see the ‘Library View’ and then clicking to navigate inside a folder will automatically switch to the ‘By Project View’.

I was interested to see what would happen if I created another view at the “Show in folder” level and tried to set it as the default. I created a view called ‘By Manager’ and set it as default.

As you can see SharePoint is enforcing that I can only have 1 default view at the folder level and this is independent of the default view at the Top-level.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.