0

I'm trying to do a permissions report for my WSS2.0 environment and found the SharePoint Administration Toolkit 4.0. I understand that the target environments are MOSS2007 and WSS3.0 but the framework is so similar between 2.0 and 3.0 that I thought I'd give it a try.

I was able to add the package using the following command:

stsadm.exe -o addwppack -filename “C:\Program Files\Microsoft\SPAdministrationToolkit\PermissionReporting\PermissionReporting.wsp”

For WSS3.0, the command is:

stsadm.exe –o addsolution –filename “C:\Program Files\Microsoft\SPAdministrationToolkit\PermissionReporting\PermissionReporting.wsp”

And the required deploysolution and activatefeature switches would be used after that to complete the deployment.

But those switches don't seem to exist for the stsadm executable in WSS2.0. My question is if there are any alternatives to the 3.0 switches or if it's simply not going to work because I'm working in a 2.0 environment.

The article I'm referencing for the installation of the SPA Toolkit is here: https://technet.microsoft.com/en-us/library/cc508849(v=office.12).aspx

  • have you tried it? are you getting any errors? – Mike Aug 4 '15 at 18:56
  • Yes, I tried those two switches after the initial command and the result is just the command prompt offering the available commands. So it's telling me that those commands don't exist for that version of stsadm.exe. The question is if there are alternatives to those switches and if not, are there any other options to make the SPA Toolkit work with WSS2.0. – user44822 Aug 4 '15 at 19:10
  • addwppack may do the installation all in one command. – Mike Aug 4 '15 at 19:20
  • I also thought that might be the case, but the features still don't appear in the site administration page for any sites. – user44822 Aug 4 '15 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy