0

I encountered this error message everytime I open management shell, I'm local administrator and farm administrator, the account is in WSS_RESTRICTED_WPG_V4 group and I run the management shell as administrator:

The local farm is not accessible. Cmdlets with FeatureDependencyId are not registered

After some google searching I found there's three popular solutions for this problem:

  1. set management shell target to C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -Version 2.0 -NoExit " & ' C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\POWERSHELL\Registration\sharepoint.ps1 ' "

This solution does not work for me.

  1. The error occurs because Windows Management Framework 3.0 is installed via Windows Update or manually.

I checked program and features, did not find windows management framework

  1. I have to set up with the following memberships to the SharePoint_Configuration database: SharePoint_Shell_Access and db_owner in SQL server.

Since I'm not the system admin I'm not sure how the sharepoint was installed, but I know we installed SQL server 2008 after sharepoint 2010 was installed, and I just checked SQL server management studio and could not find any sharepoint related data or permission so I can't really set up the memberships.

I think number 3 is the reason causing this error, but I'm not sure how to approach this problem, can someone help me about this? Thank you!

  • Here are a couple of suggestions. .. Try running the management shell as the farm account. .. Check that you have the correct sql server. .. have you set up aliases with cliconfg.exe? Will edit with more suggestions when I get to a pc. – Nullldata Aug 4 '15 at 15:22
  • @Nulldata thanks for the reply, the problem is solved as I checked in sharepoint content database, and figured out the database is hosted in another server. After granting the permission to my account in that server's SQL server management studio, I was able to get rid of this error. – SSilicon Aug 4 '15 at 16:11
0

The problem is actually pretty dumb, so I checked mange content database setting in Central admin. And found out my sharepoint database is hosted in another server, I went to that server, added my account to login and mapped it to owner of SharePoint_Configuration database. The error message stopped appearing and I was able to access to sharepoint farm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.