4

I have added a search results webpart which returns only a subset of documents. I have around 15 documents but search is only returning 7. I noticed the missing document have similar content with few modifications.

I came across this article which mentions about the Trim Duplicates attribute. Does anyone know if this issue is fixed in the Latest service packs. I have April 2015 CU.

http://blogs.perficient.com/microsoft/2013/04/sharepoint-2013-search-not-display-all-results/

4

Just open the web part and Edit the Query. On the Settings tab there is an option to disable duplicate trimming. No need to export the web part.

Remove Duplicates Screenshot

  • Added screenshot to answer – Nullldata Jun 29 '17 at 14:42
1

Hopefull this helps you,

This was answered on another site, this is what we did as well and it worked

--

https://social.technet.microsoft.com/Forums/sharepoint/en-US/3982c56e-7c22-4f25-bffa-43d313c64d52/how-disable-trimduplicates-in-the-search-result-webpart-under-sharepoint-2013?forum=sharepointsearch

This was driving me insane for days as well, and I finally found a solution. What I did was:

Add a standard search result webpart to a page Export the webpart and save it on disk Edit the *.webpart file that was exported in notepad Look for the text: "TrimDuplicates":true Change it to: "TrimDuplicates":false Save the file and and import it as a new webpart

Sorry, I cant answer the part about the service pack updating this, I dont think it will be fixed as this is probably by design...

  • I have already done that using the export option... I also found another option in Search webpart settings as mentioned in the link... I'll try that... – Kannan Jul 31 '15 at 1:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.