2

I have developed a No Code solution (based on Standard SharePoint Online functionality) in SharePoint Online/Office 365 for a customer. In every site there is a Document Library. In the Document library there are four Content Types. Each Content Type contains the Site Column "Team Category". The Site Column is of the type Managed Metadata.

When I click New in the Document Library I see the list of the four Content Types and I can create new Documents in the library based on them (as intended and the way it always works).

Everything works fine until I add the Site Column "Team Category" to the view. What happens then is that when I click "New" in the Document Library the Content types are no longer showing, instead it shows the Standard Content types (Wod Document, Excel Workbook, PowerPoint Presentation and OneNote notebook).

Sometimes it helps to clear the browser cache, then "my Content Types" are there again but if I click on another list in the site and thereafter open the Document Library again, the Content Types are gone again.

If I remove the Site Column from the view everything works again.

I have had this problem for approximately one month now (earlier it worked fine). When we first discovered the problem it only existed when we used Internet Explorer 10 or 11. When we tried with Firefox or Chrome everything worked. But Yesterday the problem was consistent regardless of which browser I was using. If a view contains a Site Column of the type "Managed Metadata" the Content Types dissappear. If I remove the Site Column from the view everything is working again.

Since I use the Content Type Hub I first suspected it had something to do with that so I created some local Content Types with local Term sets but that did not help. The problem applies to all type of sites, I have even tried standard Team Sites and the problem persists.

I have spent a lot of time trying to figure this out now but now I am more and more sure of that this is a bug. Does anyone else experiencing this problem and/or have a solution to this.

The system I have developed is intended to be rolled out to the whole company (+1000 users) within a a month so it is urgent that I find a solution to this.

I have now opened a support ticket but if anyone can come up with an answer as soon as possible i am really thankful.

  • I have opened a ticket at Microsoft Support now via the Portal. I will inform You here in case of it is confirmed to be an error/bug in SP Online. – Magnus G Jul 31 '15 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.