0

I have a hyperlink field in an Infopath form which is set to populate a file Hyperlink to a shared drive based on entries to other fields in the form, using below formula for default value:

concat("file://\\file\nmig1\Compswap\C Welsh\Database files\Business Excellence\Evidence\", Contract, "\", Area of Excellence, "\", Measure, "\", Level)

This works fine when an item is first submitted to the associated Sharepoint list - however if you try and edit an item using the form, the hyperlink entry in the Sharepoint list does not get updated.

For clarity - the Hyperlink field updates correctly to a new string within the form, it just doesn't overwrite the old hyperlink value in the Sharepoint list when the edit form is submitted.

I've searched extensively for anyone having or solving the same issue, no joy.

Anyone come across this, or have any idea why this could be happening?

It seems bizarre that it submits fine for a new item but fails to edit.

EDIT: Should add that this is on Sharepoint 2010.

0

One reason default values sometimes don't update is because the checkbox for refreshing the default is not selected. Check the field's properties to see if this box is selected: Refresh Checkbox

  • Hello, thanks for the response. Refresh value is ticked, the value itself does update within the form. However when the form is submitted, the hyperlink field in Sharepoint list record doesn't alter to reflect the new submitted string. – CapriciousMelon Jul 28 '15 at 11:35
  • So, your form submits to just a form library and the promoted field isn't getting updated? Or does the form also submit data to a separate SharePoint list/ – hilary Jul 28 '15 at 18:51
  • Hello, sorry for delay. The form is directly linked to a SharePoint list. No Form Library involved to my knowledge. – CapriciousMelon Aug 3 '15 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.