3

I create a document list called Publication groups, whose default content type is Publication. In the content type publication, there are some fields such as item no, kit number and so on.enter image description here

But I can never see the project field in the browser. I never set it to hidden. What may possible lead to this? Thank you very much.

PS: I am going to Column Order page, trying to set visibility of some column. enter image description here

Eidt:

I used CSOM code to check the hidden property of this field in Visual Studio. The hidden property is false. So it is not set to be hidden. But it doesn't show in the page. What could be wrong??? Thanks.

enter image description here

5
  • Check the values of SPField.ShowInNewForm, ShowInDisplayForm and ShowInEditForm. You can do that with PowerShell. Jul 23, 2015 at 9:16
  • @Naim, Hi, Is it possible to do that with web UI or with sharepoint designer?
    – Sun Robin
    Jul 27, 2015 at 2:26
  • No. Why don't you check with PowerShell? Jul 27, 2015 at 8:43
  • @Naim. I am very new to sharepoint. I don't know how to do that. Could you give me some documents about that? Or give me some tutor? Thanks very much.
    – Sun Robin
    Jul 28, 2015 at 8:32
  • Check my answer Jul 28, 2015 at 11:58

2 Answers 2

1

Check the values of SPField.ShowInNewForm, ShowInDisplayForm and ShowInEditForm. You can do that with PowerShell.

Open SharePoint Management Shell and run the following script

$web = Get-SPWeb http://YourSiteUrl
$list = $web.Lists["YourListName"]
$field = $list.Fields["YourFieldName"]
$field.ShowInNewForm

If ShowInNewForm is False you can set it to True

$field.ShowInNewForm = $true
$field.Update()

Do the same for ShowInDisplayForm and ShowInEditForm.

6
  • Hi Naim. Forgive me as a new bird in sharepoint. Something is wrong with Sharepoint Online Management Shell. Could you please help check? The new post is here. sharepoint.stackexchange.com/questions/150699/…
    – Sun Robin
    Jul 30, 2015 at 1:23
  • Hi Naim. I used CSOM code to check the hidden property of Project field. It is false. So this field is not set to be hidden. But It just doesn't show in the page. What could be wrong??? See my edit.
    – Sun Robin
    Jul 31, 2015 at 6:59
  • A field can have Hidden=False but if ShowInDisplayForm is False then it will not be shown in the display form (same goes for ShowInEditForm and ShowInNewForm). With CSOM you can use SetShowInDisplayForm(true). Are you checking the field taken from the list's field collection or content type's field collection. Check both. Jul 31, 2015 at 7:32
  • Hi, I find the point. Sure, you are right. I modified the ShowInEditForm to be ture, and it shows! By the way,I am just wondering when someone creates a filed in the WebUI, is it possible from him to modify it in UI? Otherwise, he has to use PowerShell or CSOM to modify it?
    – Sun Robin
    Jul 31, 2015 at 8:16
  • It can't be changed with the UI. The default value for ShowInDisplayForm, ShowInEditForm and ShowInNewForm is true unless its a column deployed with custom SP solution where (intentionally, by design) the content type schema has False value for ShowInDisplayForm etc. Jul 31, 2015 at 8:25
2

You'll need to make the column visible from the content type setting. For that you'll need to goto list setting, click on the content type and there you can set the order of the columns and also which fields are visible on dispaly, edit and new forms. Do let me know if you need a complete tutorial.

3
  • See my edit. I am in the column order page. How can I set the visibility? Thanks.
    – Sun Robin
    Jul 23, 2015 at 8:58
  • click on the field on the previous page. and see if it's hidden!
    – Taran Goel
    Jul 23, 2015 at 9:19
  • hi, this is what I am wondering. I see it is set as required, not hidden. But it never show in the web page. So this is why I am asking.
    – Sun Robin
    Jul 27, 2015 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.