1

I have a custom Content Type, and a library template with that Content Type, that includes showing the default Title column. I created a library with the template with that Content Type yesterday, and I could edit the folder Title properties (folders created in Explorer view). Today I created a duplicate library (to change the url), and the same template and Content Type won't show the Title field for folders to edit. It just shows the name of the folder. I can't do code, am just site admin without Central Admin or Designer. The Title column is showing fine as listed for this Content Type. Just a simple solution, please.

3

Create your own folder content type:

  1. On the home page of the site collection, click Site Actions, point to Site Settings.

  2. In the Galleries section, click Site content types.

  3. On the Site Content Type Gallery page, click Create.

  4. On the New Site Content Type page, type a name (for example: Folder with description) and, optionally, a description for the new site content type.

  5. In the Select parent content type from list, select the group on which you want to base this new content type. In your case, we should choose Folder Content Types.

  6. In the Parent Content Type list, select the parent content type that you want to base your content type on. Here we choose Folder. (Note the list of parent content types differs depending on the option that you selected in the previous step.)

  7. In the Group section, choose whether to store this new site content type in an existing group or a new group. Click OK.

  8. In the “Site Content Type: Folder with description” page, click Add from new site column, then type a column name (for example: Folder Description), choose the type of this column, click OK. Now a site content type has been created.

  9. To add the site content type, we browse the Document library.

  10. Click Settings > Document Library Settings > Advanced settings.

  11. Enable the management of content types, click OK.

  12. Click Add from existing site content types, choose Custom Content Types ,we will find “Folder with description” (maybe it’s not in Custom Content Types. It depends on previous settings.) in Available Site Content Types . Add it and Click OK.

  13. Now back to your Document library and click New menu, you will find the “Folder with description”.

  14. Besides, you can disable the ”Display New Folder command on the New menu” option in Advanced Settings to disable the default folder content type.

  • Thanks, this sounds great! I didn't know we could do a folder Content Type. Great solution! – Nancy Jul 24 '15 at 13:26
0
  1. Go to Library Settings.
  2. Go to Advanced Settings.
  3. Click "Yes" radio button for the field "Allow management of content types"
  4. Click OK button. This should bring you back to the Library Settings page. What is different is Content Types section displaying.
  5. Under Content Types, click Document.
  6. Scroll down to click Title under Columns.
  7. Under Column Settings, click "Optional (May contain information)" radio button
  8. Click OK button.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.