4

I am getting frequent topology errors on my SP servers:

A failure was reported when trying to invoke a service application: EndpointFailure Affected Endpoint: http://app01:32843/3984e60ee73842a1b4ea6763c844183a/SearchService.svc

I ran a command for the Search Service Application to get end points and got these results:

http://app01:32843/3984e60ee73842a1b4ea6763c844183a/SearchService.svc 
http://app02:32843/3984e60ee73842a1b4ea6763c844183a/SearchService.svc     
http://wfe01:32843/3984e60ee73842a1b4ea6763c844183a/SearchService.svc 
http://wfe02:32843/3984e60ee73842a1b4ea6763c844183a/SearchService.svc

https://app01:32844/3984e60ee73842a1b4ea6763c844183a/SearchService.svc
https://app02:32844/3984e60ee73842a1b4ea6763c844183a/SearchService.svc
https://wfe01:32844/3984e60ee73842a1b4ea6763c844183a/SearchService.svc
https://wfe02:32844/3984e60ee73842a1b4ea6763c844183a/SearchService.svc

It appears the end point on 32843 is what is causing the issue. We are using SSL and I "JUST" noticed while pasting the text in this post that the failing end points are all using http.

I have read this may be caused by an address stored on the load balancer. We have a netscaler load balancer.

Any ideas? Can I remove the http end point references somehow?

Edit: I think I found where the end point references are located. They are in IIS under the "SharePoint Web Services" site. The example images below are for the Search service endpoint. If you look to the right on the first image you will see the http/https bindings. If I click on the advanced settings, I see the "Enabled Protocols" is set to http,https. Not sure if it is supported to remove http from this entry or not. I am going to dig a little deeper now that I think I know where this is coming from.

enter image description here

enter image description here

Edit 2: I verified in our dev environment that removing the http value from the enabled protocol stopped the errors. I just don't know if this is supported by MS so I am not going to mark it as the answer until I find out more.

  • Any updates on this? – Christoffer Sep 29 '15 at 9:03
  • I have not found anything else out. I may have to open a support case with MS. It appears to be a pretty benign error, I just don't like it cluttering up my event viewer – steveareeno Nov 3 '15 at 20:37
  • Ah i managed to solve this, my problem was that i had moved my search application to it's own application server and removed the old search components but never disabled the search related services on my old application server. So what i did was stopping "Search query and site settings service", "Search Host Service" and then ran "Get-SPSearchServiceApplication -local | stop-spsearch" to stop the last service "Server Search". This removed the error for me. Basically, my search tried to listen to endpoints on server that had no search components anymore. – Christoffer Nov 4 '15 at 7:51
  • Which command you ran to get EndPoints? I am facing the same error and unable to find any clue. – Muhammad Zeeshan Tahir Apr 10 '17 at 15:14
0

This is an old question but keeps coming up in search results. What solved this same error with the same search end point for us was to add our Search Content Access account to the WSS_WPG group on all servers.

I noticed that the Account permissions and security settings in SharePoint Servers 2016 and 2019 stated this for the WSS_WPG group:

WSS_WPG has read access to local resources. All application pool and services accounts are in WSS_WPG. The following table shows WSS_WPG registry entry permissions.

This cleared up the errors, but we also ran Initialize-SPResourceSecurity -Verbose [docs link] on each server for good measure.

The Initialize-SPResourceSecurity cmdlet enforces resource security on the local server. This cmdlet enforces security for all resources, including files, folders, and registry keys.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.