0

Using VS 2013 Update 4. Office tools Udpated. SharePoint 2013 installed locally.

I can browse the site as expected.

However, when I go to VS and try to create a solution I get this enter image description here

I also cannot add an SP connection from the Server Explorer in VS. I get a popup saying "A task was cancelled".

This is a new dev VM to replace an existing one. It has SP, AD and VS all installed.

It doesn't seem to be an SP issue. I have checked the service account, app pools, database permissions etc...All good there.

There is nothing in the event log and fiddler doesn't record any attempt to ping the site.

I think it has something to do with vssphostv5.exe. I cannot find it in the task manager or process explorer. I tried to run it manually and nothing. I also tried to repair VS (this is a fresh install and the first project I am trying to create).

Despite taking hours to repair...the problem still persists.

Any ideas? I'm out!

  • did you start vs as administrator? does the health analyzer show any errors in the Central Administration? – Gwny Jul 21 '15 at 14:39
  • Yep - start as admin, always!! HA does show a few, but only the regular "disk space" stuff you get on dev boxes. – SteveCl Jul 21 '15 at 15:00
  • ok but no missing features or such? I once had some strange problems with your error message which had to do with missing assembly errors in HA. – Gwny Jul 21 '15 at 15:09
  • Nope, nothing like that. It doesn't seem like VS has even got to SP. The error pops up too fast :) – SteveCl Jul 21 '15 at 15:11
0

It sounds like a "loopback check" issue. There's two methods to resolve these detailed here: https://support.microsoft.com/en-us/kb/896861

Since this is a Dev VM I'd suggest the second method.

  • 1
    It's not this. I've already disabled loopback check - pretty standard step for a dev vm! – SteveCl Jul 21 '15 at 14:48
  • 1
    It might be a "standard step for a dev vm", but your post does not mention that you have disabled it.. – Robert Lindgren Jul 21 '15 at 16:02
  • 1
    Fair point. Loopback is disabled. I did however state that I can browse the site as expected - which would not be the case if "loopback" was getting in the way. – SteveCl Jul 21 '15 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.