1

I have built a view of my document library where the items are grouped by a couple of columns. It is set to display 3 groups per page, and display items in batches of 10. In the Library, this works as expected - each page has 3 groups, and any group with more than 10 items has its own paging control that is only visible when that group is expanded:

image of library view

But, when I try to put a List View Web Part on a page with this view, it behaves quite differently - the "groups per page" value seems to be completely ignored, and the outer paging control (which should page through every 3 groups) shows batches of 10, and applies to the items inside the groups, resulting in some really bizarre-looking group count indicators:

image of messed up web part

As you can see, the "No" group of 17 items shows me 4 of them, and the "Yes" group of 13 items shows me 6 of them. Then, when I click to the next page, it appears as though this DC/Area has only "Yes" items:

next messed up page of view

I've checked, and double-checked, and everything is definitely set exactly the same between the Library view and the view of the Web Part.

How do I fix this?

2

This occurs when "Enable Asynchronous Update" is selected in the List View Web Part. Instead of editing the view of the Web Part, you need to edit the Web Part Properties. Under AJAX Options, uncheck this box:

Web Part Properties control with circle drawn around the checkbox for "Enable Asynchronous Update"

Once you do that, your Web Part will start behaving properly on the page:

image of properly working web part

  • Another potential cause is if "Enable inline editing" is checked in the view settings, which doesn't play nice with grouping. That wasn't the case here, but if you're not using Asynchronous Update, check that setting too. – Dan Henderson May 9 '17 at 20:54
  • I have tried this, I couldn't find "Enable inline editing" in any settings. I'm trying to display a list on a page, and all I am getting is numbers "1-30" at the bottom, but I am not getting the paginated arrows in my webpart. Is this topic similar to the original question? – Rhettmartens Aug 22 '18 at 18:21
  • It looks like the "Enable inline editing" option was removed in SP2013 and later versions. The problem in this question is probably one of the reasons for that. Your issue, though, of getting the numbers but no arrows, sounds like it could be a different issue from the one in this question, so you should probably go ahead and post your own question for that. – Dan Henderson Aug 29 '18 at 14:45
0

I found the same behavior in SP 2013 that whenever any of the asynchronous update options were enabled in the web part settings on that view that the groupings were ignored. I had to disable the asynchronous load options and the option to Show Manual Refresh Button because if you have the refresh button checked then when you hit apply or save it will automatically turn asynchronous updates back on. Turning off all the options under the AJAX Options in the previous picture restored my groups to filtering properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.