I am working on SP2013 on-premise standard. When I connect to a site collection and create a new workflow with SPD2013, there is no problem.

Then I export the site (included the SPD workflow) and import it under another site collection. After then I open the new site with SPD2013 and try to open the workflow (I need to correct the GUID in workflow and publish the workflow with another user).

When try to open the workflow, SPD2013 prompt it is querying information from server, it loads very long. Sometimes the load would be completed after a min and sometimes forever. If I click "cancel" button, sometimes it will skip a step and resume to normal. However, sometimes it will lead to crush of SPD2013. Windows will ask me re-launch the SPD2013.

Is there anything I can improve the situation?

1 Answer 1


I can't say you are doing everything right, but assuming this is a random problem, there are a few things that you can try to make SPD more stable.

1. Add the /Safe parameter to SPD

Open the properties of the SharePoint Designer shortcut, and then paste "/Safe".

It should look like:

Target: "C:\Program Files (x86)\Microsoft Office\Office15\SPDESIGN.EXE" /safe


(switch only, no parameter)

Starts Office SharePoint Designer 2007 in Office Safe Mode, which allows you to safely use an Office or Office family program that has encountered certain startup problems. When a problem is detected at startup, Office either fixes the problem or isolates it, allowing the program to start successfully.

2. Clear SPD Cache

Delete contents of these folders



%appdata%\Microsoft\Web Server Extensions\Cache

3. SPD Crashing on Open Site

In my case, I also had to remove the ClientGUID keys in order for SPD to Open a Site.

HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Open Find\Microsoft SharePoint Designer\Settings\Open Site


HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Open Find\Microsoft SharePoint Designer\Settings\Open Site

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.