You can hide a list or library in Sharepoint Designer from the browser, but it is also getting hidden from the Designer.

How can I unhide a hidden list or library? It is not consistent which of them I can find in the All Files section and which not. Lists are all gone from the Designer and also Browser. For example the Pages library I can find also afterwards there.

Duplicate of Unhide List/Library from Browser.

3 Answers 3


You can unhide the hidden list with Sharepoint Designer.

SP Designer -> All Files -> Lists -> on hidden list name folder right click and properties -> settings section -> uncheck Hide from browser


You can go to...

SP Designer / Options / Application Options / General / General / Show catalog lists and system objects

...that was un-checked by default. Checking it allows you to see the hidden items under "Lists and libraries" section of the "Site Objects" browser of SharePoint Designer. Then you can go to the properties of the desired hidden List or Library and uncheck the "Hide from browser" option.

Sharepoint Designer Application Option Dialog


A potential reason why a list no longer appears in SharePoint Designer after you mark it as hidden is usually when the permission level for your user account do not allow you to see hidden lists.

This happens for example, when you are site owner (full control), but not site collection administrator.

In order to set the list back to visible you (or someone else) needs to open SharePoint Designer as Site Collection admin and change the setting.

  • My user account is Site Collection admin. Commented Jul 21, 2015 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.