0

I have been building a SharePoint app in the NAPA Office 365 Development Tools. Recently (due to some weird bugs) I wanted to use Visual Studio's debugger so I opened the code in VS. However, when I attempted to compile the code I got the following error:

Error 2 Could not load file or assembly 'Microsoft.Office.SharePoint.Tools, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.

Most everything I've seen told me my problem is that I'm trying to use VS 2010 with SP 2013, which is a no no. Issue is, I am currently in VS 2012. Is there a further error I'm unaware of?

I can add the code, but as it is like 700-900 lines worth of code, so unless people need to see it I was leaving it out.

2

I was also getting same error:

could not load file or assembly microsoft.office.sharepoint.tools.dll or one of its dependency.

I was working on SharePoint 2013 App Development (SharePoint Online). Everything was working smoothly. Suddenly I started getting error when I deploy the app. My office got uninstalled because of some reason. It also leads to uninstalled few components related to SharePoint office.

I found SharePoint Online development have dependency on "SharePoint Server 2013 Client Components SDK". You can download it from https://www.microsoft.com/en-in/download/details.aspx?id=35585

After download, verify that components are installed properly by following "C:\Windows\Microsoft.NET\assembly\GAC_MSIL" path.

enter image description here

Close visual studio and open it again. Deploy your app, login with your credentials in tenant and check.

Please let me know this helps you or not?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.