0

I have a site collection, to be more precisely it is Search Center, where i applied read access to "Everyone" (i'm using ADFS only, (different zone for search crawl which uses windows authentication)). "Everyone" have access given through Visitors group (default one). However, when I test access to that site it says: Sorry, this site hasn't been shared with You. If I add "Everyone" to Members group (with edit rights) I can access it without any problems. So seems like Read permissions are not applied.

I have tried to create new SharePoint Security group with Read permission level, but the result was the same. So i have to add people at least with Edit permission level so they can see the site, otherwise they will not succeed to browse to page. I have created new site collection (also search center) and there, the Read access works. So, i think the solution would be to delete this site collection and replace it with new one.

PS This is SharePoint 2013

Anyone have any idea what could be wrong? What might be the issue?

Thanks in advance

  • Are all of the pages and display templates Published? – Matthew McDermott Jul 15 '15 at 13:49
  • Have you broken inheritance for any of the content in the site? It should show a notice of this on the site permissions page. – Jan Jouke Tjalsma Jul 15 '15 at 21:16
  • Hi! Thanks guys for responses. Well, i have published any page nor display template. That should not be the case - i have created another search center site collection (in the same web app) and it works fine - i haven't published anything there. I have never had to publish any page in Search Center to make it working (if all is used as created by default). – Kamil Jul 16 '15 at 20:33
  • I haven't broken inheritance. That is really weird problem. I suspect there is some problem with the site collection itself. – Kamil Jul 16 '15 at 20:37
0

so it turned into an unsolved problem. I have removed the site collection and created it from scratch. It works now. So the problem was specific just for this one site collection and i have no clue why it has happened.

Regards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.