1

Version 2013 I need to set item limit for a normal discussion list.

The 'subject' view is not editable (grayed out) as well as the flat view.

By going into the list settings and edit views from there I do not see the typical list of features that I can change (filtering, sorting, item limit etc)

Is there something I am missing or it is simply not possible to set item limit in the subject view of a discussion board?

I do not have edit view

  • I try it and its works but it's RowLimit not RowCount – user52659 Mar 25 '16 at 14:27
3

I had this same problem. My discussion board is on a publishing site, not team or community. The views are not editable.

The only solution I found is to edit the list in SharePoint Designer. Go to the discussion board and on the ribbon click to edit the list in SharePoint Designer. When it opens, click the view you are using (like subject) then you get a page full of code.

Do a find in page on the word row and you'll find a rowcount. The default is 20. Just type in the number you want and save (ctrl + s). If you're displaying your discussion board in a web part edit the web part and "reapply" the view.

0
  1. Create a webpart page
  2. Add Discussion board list view webpart on that page
  3. Edit the webpart settings
  4. In Properties you can edit the current view.

enter image description here

  • I do not have edit the current view for the Discussion board. It is a different type of list than the rest. – susan Jul 14 '15 at 12:18
  • Strange..I have done this for discussion board. And for me it worked. – P S Jul 14 '15 at 12:51
  • 1
    version 2013? and it is not the comunity site template, it is a discussion board list – susan Jul 14 '15 at 14:00
  • Yes I have done in 2013, Team site template. Added the discussion board on Home page and then changed the view settings there. – P S Jul 14 '15 at 14:20
  • I do not have edit the current view, i do not even have the space underneath the drop down box see above for image – susan Jul 14 '15 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.