1

In the Content Type Hub I have the following two content types: Company Document:

enter image description here

and Collaboration Document which is inherited from the Company Document. Notice the difference in required fields:

enter image description here

Due to strict security policy here at the company, I had to hide parts of the names.

I have a custom Document ID provider developed, deployed and configured.

Scenario:

  1. A new site collection gets created. A couple of custom libraries with Collaboration Document content type are added to the site by a feature receiver.
  2. Both content types (Company Document and Collaboration Document) look fine (configured exactly the same as in the Content Type Hub) in Site Content Types and in Library Content Types.
  3. For the Document ID to work with the Content Types from the Hub, I need to go to Content type publishing, select Refresh all published content types on next update and click “Ok”. Otherwise Document ID Generator event receivers won't be added to the content types. After running Content Type Subscriber job everything is fine and the Document ID starts working.

The problem is that the content type Collaboration Document gets updated in all the libraries and it looks like this:

enter image description here

(sorry for the change in branding). So it inherits required fields from its parent content type Company Document and not from the content type that it is supposed to inherit from (Collaboration Document). To add more confusion, the site content type looks like this:

enter image description here

(which is absolutely fine). So it’s fine at the site level, but it messes up at list level. If I create a new list AFTER refreshing the content types from the hub, the libraries seems fine and the required fields are configured how they are supposed to be.

Inherits is set to True as this is a requirement.

Does anyone have any thoughts on this? How can I make sure that the required fields are based on the correct content type? Or maybe is there a way how to get Document ID working without doing the Refresh all published content types on next update?

Any help appreciated.

Update: Had to set Inherits to False, otherwise it wouldn't work.

  • With Document ID, do you mean the Ids you get after activating Document ID service? – Asad Refai Mar 2 '16 at 9:27
  • Yes, but we have a custom Document ID provider (though, it shouldn't impact anything). I had problems with Inherits set to True before, especially with Document Sets and Document IDs. – Paul Strupeikis Mar 2 '16 at 9:47
  • This problem seems quite old. Did you manage to solve it? P.S.: Just setting inherits to false you managed to solve it right? – Asad Refai Mar 2 '16 at 9:51
  • 1
    Basically the solution was to set Inherits to False and then provision each list with an event receiver, which would set the field properties properly. – Paul Strupeikis Mar 2 '16 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.