1

I'll try and be as clear and concise as possible. Within SharePoint 2013, Global nav has been working fine for me, and suddenly now all newly created pages will not show in Global Nav. In the settings page, they are shown as "Show" not hidden.

Tried fixes:

  1. Increased the number of dynamic items shown, no change.
  2. Moved the new page up the nav list till it was the first item, still doesnt show.
  3. Also noticed it wont show in current nav either.
  4. The permissions are fine, I even gave myself every permission under the sun for that page.
  5. BUT, if I remove the manual ordering, and have auto ordering, all the new pages show. Very strange?
  6. Adding a manual text link in Global Nav settings works, and shows.

I'll keep adding to this list as I try new fixes. But if someone can help? I am truly clueless as to why this is happening.

  • 1
    If you post some snapshot, it would be great to identify your issue. But as per you question I suggest you to check what option is selected inside the Site settings > Navigation. – Pradip R. Jul 10 '15 at 10:42
  • Hi, thanks for the reply, but snapshot of what... As it's missing I can't snapshot anything. The pages shows in navigation settings in global and current nav, but not on the actual pages. Other pages do appear. Just not new ones. – redfox05 Jul 10 '15 at 15:09
0

I just ran into this with a site I was working on. There is a limit in the SharePoint web.config file on the WFE server that your site is hosted on. Follow this link of instructions to fix it. https://social.msdn.microsoft.com/Forums/sharepoint/en-US/733ab51a-54d5-4463-8466-32d182b97988/quick-launch-only-dynamically-displays-50-sites

My problem was that apparently I applied the fix to the wrong Web Application... I could have sworn that it was working before but it wasn't there when I finally went back to double check it. The default limit is 50 dynamic links (which appeared to actually be 49 for me, or 25...?) even if you change the limit in site settings -> Navigation the links over that limit just won't show up.

0

I had a similar issue where my newly created pages were not showing in global navigation. As I searched and tried various suggestions, nothing worked.

I finally noticed all of the new pages were checked out to me. When the new pages were created, I didn't do an initial check in. Once I checked in the new page, it appeared in the navigation. I did the same thing for the other 13 pages, and now all are showing, and I am also able to sort them manually in the navigation setting menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.