0

So I followed a CBT Nugget instruction on setting up an InfoPath 2013 Form and getting it all connected to SharePoint 2013 so that it could be filled out by users via the browser and then set up an approval workflow behind it to start whenever a form was submitted.

All of that is working fine except for the Submission of the form. When you hit the submit button, it acts like it's doing something (it closes out the form) but there's no data saved anywhere. I did the data connection properly as far as I can tell from following the instructions in the video.

However, if I fill out the form and then hit Save or Save As, give it a title manually, then hit Save in that dialogue box and close out of the form, the data is now visible in my SharePoint library and my workflow is triggered accordingly (basically like it was submitted).

I tried setting the submit button up with rules and also with the basic submit button features, but I get the same results both times. Does this mean that the data connection is not correct after all? I've been googling this but I don't seem to be able to find someone with this same problem.

  • is it a browser enabled form? – Gwny Jul 10 '15 at 6:31
  • Yes it's browser enabled. – Sarah Anderson Jul 10 '15 at 14:31
  • Don't you want to choose an InfoPath alternative? PDF forms are much easier to desing and deploy... – Degi Karayev Jul 13 '15 at 17:10
  • Is your submit connection pointed to the correct library? Are your submit options configured to use the submit connection? – hilary Jul 13 '15 at 23:25
  • Yes and yes. I double-checked that and even made a completely separate library and form just to see if something weird was going on with that form. But it's still the same issue. If I hit submit, no data actually gets submitted but when I save then it's there. I don't know what the issue could be. I'm still trying different things though to see if I can figure it out. – Sarah Anderson Jul 15 '15 at 14:28
0

Make sure that you have all the correct columns checked off within your Library view. If they are not checked off the data will not show up because it has nowhere to go. Also, make sure you made the form save underneath a specific title each time (you can use feilds to custimize your form name each time it is filled out.)

  • I've got them all checked in the library view. I created a completely separate form with just two fields to check this problem and it's still the same issue. And I have set a title for it to save under when the submit button is used, but that never executes when you hit submit anyway. – Sarah Anderson Jul 15 '15 at 14:25
  • I had an issue close to this the way i fixed it is I compeltely removed the data connection I had an started from scratch: Make sure u go to the bottom right underneath your feilds click Manage Data Connections.. Click Add..Create new connection to: (SUBMIT Data) next to a document library on a Sharepoint site, make sure you paste the link to the main library you will use ( give it a unique name) and make sure it is saved as a Default submit connection after.. you can also Republish your form to a SharePoint Server to double check if maybe a connection there went wrong ( in File -> Publish) – VKay Jul 15 '15 at 14:35
0

Okay, I figured out what the issue was. The instructions that I had said that you were not supposed to include the /form.aspx at the end of the URL for connecting the document library, but that is apparently not true. I decided to try and add it in to see if it would work and now my submit is working just as it should be! Thanks everyone, sorry for the confusion. I'm glad I got it figured out though! I was getting frustrated!

protected by Community Oct 8 '15 at 19:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.