Our SQLserver db containing the SharePoint config db went down, hardware failure, the content is on a different server, managed to get the config db from backup,

i ran stsadm -o delete configdb, but I keep getting 'access denied' when I try to reconnect to the old config db on the new server from the command:

stsdam -o setconfigdb -connect -databaseserver (newservername) -databasename SP2007_config -farmuser (SP farm admin user) -farmpassword (password)

after playing around with permissions and making sure everything is well permission wise, i got:

a network-related or instance-specific error occurred while establishing a connection to SQL server.... (provider: Named Pipes Provider, error 40 - could not open a connection to SQL server)

allow remote connections to server is turned on, I am running stsadm on the same server because its all a 'one box' farm expect the config db was on a seperate box which is down????

tried psconfig and it hangs on;

Performing configuration task 2 of 3 Connecting to the configuration database... THEN

Failed to connect to the configuration database. An exception of type System.Security.SecurityException was thrown. Additional exception information: Access denied.


You dont mention the version of SharePoint you are using, but since you mention stsadm i am gonna assume you are using SP2007.

You should follow this guide on technet. Be aware that the procedure varies depending on if you are running named instances (alias) or not.

For SP2010 use this article instead.

| improve this answer | |
  • thank you :) it was SQL Server Native Client Network Utility that i was missing – Singa Jun 20 '11 at 6:46
  • after having successfully moved the configdb, i ran configuration wizard and it confirmed the farm was now using the configdb on the new server but while troubleshooting why 'search' is not working, i noticed that under CA > Servers in Farm, it says the config database is on the old server even though configuration wizard says its on the new server? – Singa Jun 22 '11 at 2:18

I was able to solve this issue but changing the parentID in the config database check the link below to the post


| improve this answer | |

Remember to view if there exists a string connection of SharePoint_Config data base in SharePoint Server's Registry

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.