1

I have created two lists. I wanted that when ever a user creates an Item in List1, the same item to be automatically created in List 2.

I have configured a SharePoint 2013 Workflow for the same. When admin creates a list, the workflow works fine. But when a Member creates, the workflow throws following error in two stages.

Phase 1 :

Suspend this workflow

Activity in progress

Retrying last request. Next attempt scheduled in less than one minute. Details of last request: HTTP NotFound to http://etheem/_vti_bin/client.svc/web/lists/getbyid(guid'a0f94a5f-128e-41ec-b9f2-f65aa815be03')/Items(19) Correlation Id: 4660ef44-a8f2-fdbb-9346-876122bb60f0 Instance Id: d67989ea-8a33-4da9-806f-a22ad31899c4 Retry now

Phase 2 :

Resume this workflow

RequestorId: 4660ef44-a8f2-fdbb-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 404 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["28"],"SPRequestGuid":["4660ef44-a8f2-fdbb-a10a-063e3a4cd1c2"],"request-id":["4660ef44-a8f2-fdbb-a10a-063e3a4cd1c2"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4569"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Fri, 03 Jul 2015 05:46:30 GMT"],"Server":["Microsoft-IIS/8.5"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

  • Is member has edit access on 2nd list? – P S Jul 3 '15 at 6:02
  • What access does member have on site, list 1 and list 2 ? Also can member manually create item in list 2 ? – Monica Jagani Oct 12 '17 at 13:04
1

Use the App step feature include the workflow and check once.. if it works fine with App Step then the users having a permission issue against the list for performing the operations

please check the below link

Create a workflow with elevated permissions by using the SharePoint 2013 Workflow platform

0

If you examining the Stack Trace carefully you will see HTTP 404 error. Which means you gets not found error. I believe you don't have sufficient access to the resource.

Have you broken the security inheritance of the list ? Try whether you can see the list item by login to the particular site or app ( in your case item id 19)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.