1

SharePoint 2010 site upgraded to 2013. There is a web part on the home page that displays a list of recent blog posts from a subsite. Just displaying, works just fine. When I choose to Edit Web Part, I get the "Sorry, something went wrong" page.

ULSViewer is showing an error for an "Invalid field name. {1df5e554-ec7e-46a6-901d-d85a3881cb18}" thrown by SPFieldCollection.GetFieldById when I look up the correlation ID from the Technical Details of the error page.

In the exported web part, this GUID is not referenced. However, the TitleUrl property is /BlogSubSite, and the ListGuid property is also defined. I wrote a simple PowerShell script to iterate through that subsite's lists, found the one identified by ListGuid, and found in that list's fields a field with the GUID referenced above in the error message ("Created By"). "Created By" is not referenced anywhere in the exported web part XML.

Any ideas of where else to go with this?

  • Any luck on this issue. I tried the following article however still getting the same exception message after following all the steps. Now there is no column with this GUID in my site collection but exception persists :( Invalid Field Name – Jawad Aug 12 '15 at 20:01
0

I did find an answer to this issue. In my particular instance, there were several issues that were cropping up, including the one above. I solved all of the issues by forcing the de-activation and activation of the fields feature and several publishing features using stsadm.

Just de-activating and re-activating these features fixed the initial problems, but doing them out of order also disabled some publishing features on existing pages. I ended up creating a backup and restoring to a sandbox site multiple times in order to test different orders of de-activation and activation.

stsadm -o deactivatefeature -name publishingresource -url "sitecollectionurl" -force
stsadm -o deactivatefeature -name publishingweb -url "subsiteurl" -force
stsadm -o deactivatefeature -name publishingsite -url "sitecollectionurl" -force
stsadm -o deactivatefeature -name fields -url "sitecollectionurl" -force

And then re-activate the features in the reverse order. The fields feature could be de/re-activated either at the beginning or the end.

It's possible I have these in the wrong order, so I'm going to double-check and will come back and update this item.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.