I've taken my moss 2007 db backup and used attach method to upgrade on sharepoint 2010. Upgrade went successful and users can see the sites and can navigate also. Interface is same as moss 2007. I am facing two problems on migrated portal.

  1. I can only Visual upgrade HOME site and on other sites when i click on VISUAL UPGRADE i see "File not found" error.

  2. Some of the lists which contains pdf documents, word files and excel files when portal contributor who has rights to upload, edit and delete permissions when user clicks on any document to perform operations it says "List does not exist The page you selected contains a list that does not exist. It may have been deleted by another user." But when I tried creating a new list the user was able to perform upload, delete etc..strange..but not working with existing lists.

How to resolve the above mentioned issues...I am new to moss so kindly guide by giving a hint where to find options to fix it. Would appreciate guidance like for example go to Site Settings-> Visual Upgrade ..etc

  • I'm wondering if we should split this into two questions?
    – Kit Menke
    Jun 17, 2011 at 16:22
  • but connected to after migration issues guys...wanna split questions? u can as long as i get solution. no debate
    – user239684
    Jun 17, 2011 at 18:45
  • 1. Rather than doing visual upgrade, I would iterate through the sites and set the master pages individually. Do you have a custom master page? Or are you pointing both System master and custom master page to v4.master? Here is a script that would go over the webs and upgrade to v4.master, change version and make it so that you wont go back to v3 again via url. (vasya10.wordpress.com/2011/03/26/…)
    – vasya10
    Jun 17, 2011 at 21:46
  • thanks but what about the list issue which is major for me at this moment :(
    – user239684
    Jun 18, 2011 at 4:31
  • 1
    Well finally i did solve the problems by myself. It was the issue with the incorrect Alternate Access Mapping :) ..I've changed the intranet one and it worked :) Viola !! :)
    – user239684
    Jun 18, 2011 at 6:59

2 Answers 2


Check if its still pointing old URL. ULS logs would be much handy to solve this.

MOSS 2007 has a /default.aspx page which now converted in SharePoint 2010 to /pages/default.aspx or /sitepages/default.aspx. You may need to create a new page as default page and put the content back on it or use SharePoint Designer > All Files to locate the old page.

Hope it helps.


As mentioned in the comments, the issue was caused by Alternate Access Mappings misconfiguration.

"File not found" errors in web parts and application page UI are often indication of underlying FileNotFoundExceptions thrown in the case of requesting a non-bound host header from an existing SharePoint web application.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post.
    – Waqas Sarwar MVP
    Oct 21, 2014 at 18:47
  • This question is very old and has a resolution in the comments above not likely to be improved, but isn't exactly unanswered anymore. I marked the answer as community wiki, so feel free to improve the answer as necessary. Neither you, nor I shall gain any additional reputation, however. Oct 21, 2014 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.