0

I have a SharePoint farm running over HTTPS. Office Web Apps is also installed on another server.

When I open a office document, say a xlsx file, the file doesnt open in the browser. In Chrome I had a look at the console view of the page and it says the following

Mixed Content: The page at 'https://myzone.lom.com/sites/TFK2/_layouts/WopiFrame.…es%2FTFK2%2FInvoices%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1' was loaded over HTTPS, but requested an insecure form action 'http://owa2013.lom.com/x/_layouts/xlviewerinternal.aspx?ui=en%2DUS&r…k2%2F%5Fvti%5Fbin%2Fwopi%2Eashx%2Ffiles%2F8f5d1a64fa0945e4a6cd2d78dfbda9f4'. This request has been blocked; the content must be served over HTTPS.

This leads me to believe that this isnt working as OWA is setup to use HTTP and the sharepoint application is setup to use HTTPS.

So I found this command to check my SPWOPIZone, using Get-SPWOPIZone and it came back as "internal-http".

My question is, what do I need to do to sort this out? Should I run

Set-SPWOPIZone -zone "internal-https

Would this negatively impact my farm? Can I change it back to "internal-http" as if nothing happened :-)

Weird thing with all of this, it works fine with Internet Explorer, the xlsx document is rendered in the browser, my feeling here is IE is more forgiving.

Hoping someone can help, a part of me just wants to change the zone to internal-https and be done with it, but this is a production server, so I better not :-)

2

If your SharePoint sites are delivered via HTTPS, you should also enable HTTPS on your OfficeWebApps-Server.

Only changing the WOPIZone to internal-https will probably break your OfficeWebApps functionality.

To change your OWA-config from HTTP to HTTPS you need a SSL-certificate for your OWA-Hostname (owa2013.lom.com). You should save your current configuration via "Get-OfficeWebAppsFarm" and then remove the configuration with "Remove-OfficeWebAppsMachine". Then you can reconfigure the OWA-Server according this guide and adjust SharePoint WOPI-config.

  • Hi, So if we just enable SSL on owa2013.lom.com, then it should be okay? OR do we still have to enable SSL, save config, remove config and reconfigure? – Chunkyfeather Jul 3 '15 at 9:11
  • 1
    Just enabling SSL in IIS will not work. Please follow all provided steps to configure SSL for OWA. Sounds like a lot of To-Do, but it's just some lines of PowerShell. – MHeld Jul 3 '15 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.