0

I am running into a problem where I have a Document Library with 2 Choices column. Each has it's own options. The problem is when I use the Datasheet View to edit these columns (or one of them), then I got "Cannot access a closed stream" error and it won't save my changes.

I've dogged into ULS Logs to find exact same message with no further explanation on why it happened.

Can someone pin point on where I should look for clue regarding this problem? Maybe another log or XML message? Anything I can lookup for and get the root cause of this problem.

Here is the picture of the error:

enter image description here

Thank you

Update: The following are the links I have found and unfortunately have different case than mine, or at least, maybe if I have missed some clue from them, however did not solve my problem.

0

I found a few things that could potentially be the issue. It could be browser setting or Office corruption. You may also want to check to make sure that datasheet view isn't read-only.

Check these links for more details.

  1. SharePoint Datasheet view in Read-only mode ? Try these Solutions
  2. Unable to enter new item in Task list through Data sheet view
  • thanks, but those links didn't help, I have discovered them previously as well. but thanks – Arief Jun 28 '15 at 14:22
  • is it just this one library that is giving you this issue? – jpollar Jun 28 '15 at 14:23
  • No, in fact I tried to create another one, new Document Library with default template, with Choice column the same as above picture. But with the same error message. – Arief Jun 28 '15 at 14:34
  • is it just that particular column then? or is it doing it for all choice columns? have you tried not adding a choice column to see if you still get the error? – jpollar Jun 28 '15 at 15:28
  • Apparently I still get the error even with normal single line text column. – Arief Jun 28 '15 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.