0

I've been attempting to update an InfoPath form on a Document Library. The form works by having custom submit rules and data connections that allow the form to be submitted in specific folders. During the update I've added some more folder and setup their submit rules and data connections. Whenever I try to submit a form on one of the new folder I get this error.

An error occurred while using the form. For more information, contact the site administrator.


An entry has been added to the Windows event log of the server. 

Log ID:5567

It also has a correllation ID included and when I look up that In the logs I see this.

06/24/2015 08:55:47.30  w3wp.exe (0x777C)                           0x5C6C  SharePoint Foundation           Monitoring                      nasq    Medium      Entering monitored scope (Request (POST:http://servername/_layouts/15/Postback.FormServer.aspx)). Parent No  
06/24/2015 08:55:47.30  w3wp.exe (0x777C)                           0x5C6C  SharePoint Foundation           Logging Correlation Data        xmnv    Medium      Name=Request (POST:http://servername/_layouts/15/Postback.FormServer.aspx)  
06/24/2015 08:55:47.31  w3wp.exe (0x777C)                           0x5C6C  SharePoint Foundation           Authentication Authorization    agb9s   Medium      Non-OAuth request. IsAuthenticated=True, UserIdentityName=0#.w|domain\sptest, ClaimsCount=28    
06/24/2015 08:55:47.32  w3wp.exe (0x777C)                           0x5C6C  SharePoint Foundation           Logging Correlation Data        xmnv    Medium      Site=/  
06/24/2015 08:55:47.33  w3wp.exe (0x777C)                           0x5C6C  SharePoint Foundation           Web Controls                    cm8z    Medium      Failed to get SPGroupName from GroupID. Error Message: Group cannot be found.  Callstack:    at Microsoft.SharePoint.WebControls.PeopleEditor.set_SharePointGroupID(Int32 value).   
06/24/2015 08:55:47.38  w3wp.exe (0x777C)                           0x5C6C  SharePoint Server               State Service                   8kfs    Medium      The StateManager is disposing and calling ReleaseLockedStates() (Count=0)   
06/24/2015 08:55:47.38  w3wp.exe (0x777C)                           0x5C6C  SharePoint Foundation           Micro Trace                     uls4    Medium      Micro Trace Tags: 0 nasq,3 agb9s,27 cm8z,48 8kfs    
06/24/2015 08:55:47.38  w3wp.exe (0x777C)                           0x5C6C  SharePoint Foundation           Monitoring                      b4ly    Medium      Leaving Monitored Scope (Request (POST:http://servername/_layouts/15/Postback.FormServer.aspx)). Execution Time=80.4445816437564    

I only get the error when I try to submit on a new folder. When I submit on an existing folder everything submits normally.

Does anyone know how to resolve this error?

0

I figured out the issue.

I went back a looked through the form submit rules I created, and some of the values were not coded correctly.

one value that needed to be set to true() was hard coded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.