0

I have updated the SSL that I use for Google Authentication within a SharePoint 2013 environment that we have.

The SharePoint version is 2013, Enterprise, running the Feb 2015 CU.

The internal AD authentication is working as expected, however the application that has been extended and is accessed externally is thowing the following error message:

>     Sorry, something went wrong
>     An unexpected error has occurred.
>     Technical Details
>     
>     Troubleshoot issues with Microsoft SharePoint Foundation.
>     
>     Correlation ID: ee1d139d-9cc5-4015-8bea-880a8e68c281
>     
>     Date and Time: 6/23/2015 10:14:01 AM
>     Go back to site

I see the following error in the event log when:

> Event code: 3008  Event message: A configuration error has occurred. 
> Event time: 23/06/2015 10:14:01  Event time (UTC): 23/06/2015 09:14:01
> Event ID: c76bdd27cf9c40c988583bde3c98b54e  Event sequence: 191  Event
> occurrence: 116  Event detail code: 0    Application information: 
>     Application domain: /LM/W3SVC/1682078101/ROOT-1-130795236032204882 
>     Trust level: Full 
>     Application Virtual Path: / 
>     Application Path: C:\inetpub\wwwroot\wss\VirtualDirectories\my.website.com443\ 
>     Machine name: DZSPFT01    Process information: 
>     Process ID: 10960 
>     Process name: w3wp.exe 
>     Account name: MyDomain\Service.Account    Exception information: 
>     Exception type: ConfigurationErrorsException 
>     Exception message: The connection name 'LocalSqlServer' was not found in the applications configuration or the connection string is
> empty.
> (C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config
> line 259)    at System.Web.Security.Roles.Initialize()    at
> System.Web.Security.RoleManagerModule.OnLeave(Object source, EventArgs
> eventArgs)    at
> System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
> at System.Web.HttpApplication.ExecuteStep(IExecutionStep step,
> Boolean& completedSynchronously)
> 
> The connection name 'LocalSqlServer' was not found in the applications
> configuration or the connection string is empty.    at
> System.Web.Util.SecUtility.GetConnectionString(NameValueCollection
> config)    at System.Web.Security.SqlRoleProvider.Initialize(String
> name, NameValueCollection config)    at
> System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings
> providerSettings, Type providerType)
> 
>     Request information: 
>     Request URL: http://my.website.com/_layouts/15/1033/styles/corev15.css?rev=OqAycmyMLoQIDkAlzHdMhQ==
> 
>     Request path: /_layouts/15/1033/styles/corev15.css 
>     User host address: 10.13.190.5 
>     User:  
>     Is authenticated: False 
>     Authentication Type:  
>     Thread account name: MyDomain\Service.Account    Thread information: 
>     Thread ID: 47 
>     Thread account name: MyDomain\Service.Account 
>     Is impersonating: True 
>     Stack trace:    at System.Web.Security.Roles.Initialize()    at System.Web.Security.RoleManagerModule.OnLeave(Object source, EventArgs
> eventArgs)    at
> System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
> at System.Web.HttpApplication.ExecuteStep(IExecutionStep step,
> Boolean& completedSynchronously)

I have re-run the product configuration wizard to try and repair the install, but I still see the same error.

I'm pretty sure simply updating the SSL hasn't broken this. I have had a look around for the specific error and double checked the "Role Manager" module in web.config for both of the sites - they match.

There haven't been any direct changes to the web.config.

Any advice would be appreciated.

1 Answer 1

0

Finally had a brainwave and looked into this and got it resolved.

I had been configuring some connection strings for another service and had somehow edited the connection string on the sharepoint environment rather than the alternate service.

Aquick trop to the connection strings in IIS for SharePoint and I removed the false one, and added in one for "LocalSqlServer" with these settings:

data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|aspnetdb.mdf;User Instance=true

A restart of IIS and it's working perfectly fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.