I have just purchased a office 365 business essentials subscription. Within the team site I need to modify the out of the box Edit Form for a new custom list. However, the Form Web Parts button from the ribbon is disabled. I am the global admin so do not think this is a permission issue. Any help would be much appreciated.

  • Are you editing the edit form in SharePoint Designer, InfoPath or in the browser?
    – Graham
    Jun 20, 2015 at 17:45
  • I'm trying to edit any of the forms within the browser.
    – Nick
    Jun 20, 2015 at 18:55
  • I have experienced the same problem on many different office 365 tenants.
    – Nick
    Jun 20, 2015 at 18:56
  • are you using IE 11 by any chance? Jun 22, 2015 at 7:23
  • Have tried IE11 and Chrome.
    – Nick
    Jun 22, 2015 at 19:27

2 Answers 2


I can confirm that the button "Form Web Parts" button is disabled, but if you "Edit" the page you will get the same effect on "Display Item" and "Edit Item" form. So this button is obsolete.


This was asked a long time ago, but I thought I would answer it for future reference. This happens for a couple of reasons.

First, you need to make sure your list is using Classic and not Modern Experience, but this is not the case with your question, since you mention that the Ribbon is visible.

Since the List is clearly using Classic Experience in this case, the next step is to make sure the Tenant is configured to use Custom Scripting. To configure this you will need to be logged in to the Office 365 Tenant using a SharePoint Administrator Account.

  1. Open the SharePoint Admin center. Please note you may need to enable the advanced admin center user experience. The simple experience
    displays only the essential options. The advanced experience shows
  2. Select Settings.
  3. Under Custom Script choose:
    • Allow users to run custom script on personal sites
    • Allow users to run custom script on self-service created sites
  4. Select OK. Changes will not take effect for about 24 hours.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.