0

We had a distributed cache problem, so we removed the old one and created a new one. Now all front end servers only list Distributed Cache under the configurable view, and all application servers list nothing for the configurable view. The list was quite long prior to us creating a new distributed cache.

In Manage Service Applications, the list looks normal and every service application has a Started status. But, whenever we click on any of the service applications, they error out. Secure Store says it's not responding, Search Service still shows my topology but the System Status says it is unable to connect to the machine, Managed Metadata says it's unavailable.

I feel that something got disconnected when we created the new distributed cache, but I am not sure.

Thanks in advance,

0

Looks like something really goes bad while deleting the old DC.I am afraid to say this may be you need to rebuild the farm.

Now i would recommend the following things.

  1. reset IIS On all servers( even reboot them) to see if that fix the problem.
  2. Another solution is run the config wizard on the all servers start from Central admin box.

Also if you see any error in event log/ ULS logs please share it.

  • From the Event Log: Event ID 5586 Unknown SQL Exception -2146893055 occurred. Additional error information from SQL Server is included below. A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The handle specified is invalid) Event ID 8193 Volume Shadow Copy Service error: Unexpected error calling routine RegOpenKeyExW(-2147483646,SYSTEM\CurrentControlSet\Services\VSS\Diag,...). hr = 0x80070005, Access is denied. Event ID 8077, 6398, 5586 – Jon Smith Jun 18 '15 at 20:07
  • this is about the access to SQL, make sure your AppPool account, Farm admin account have permission on the sql server – Waqas Sarwar MVP Jun 18 '15 at 20:40
  • I did that and still no change. I use DPM 2012 for backup. Can I use it to restore the SharePoint_Config or SharePoint_AdminContent databases? Is that a way or reverting back the changes I made that cause my main problem? – Jon Smith Jun 18 '15 at 20:59
  • Hey @Waqas, I've been working on this all weekend and still no luck. What is the easiest way to rebuild the farm? – Jon Smith Jun 22 '15 at 6:34
  • Is it as simple as installing a central administration on a different server and then removing the production servers from the old farm and joining them to the new farm? My setup is 2 WFE, 2 apps, and a sql cluster with 2 db servers. – Jon Smith Jun 22 '15 at 6:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.