4

When I upload a document in my document library in my SP 2013 site collection, I am getting the below error:

The URL 'CB/30Apr2015_ConfidWF.xlsx' is invalid. It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web.

What may be causing this error?

3
  • 1
    what is status of your site collection / content DB? site collection reached to quota? content db reached to maximum point or no space left on sql server data drive etc?
    – Waqas Sarwar MVP
    Jun 18 '15 at 13:22
  • Waqas, my site colle's size is 53GB. It did not cross the 250 GB limit. Jun 24 '15 at 6:17
  • And it turned out that,its RBS issue.Customer has implemented Metalogix RBS solution and in configured for uploading huge size files in the document library,and it adds a profile in each site collection. The profile was corrupted,for this site collection, it seems. Jun 24 '15 at 6:23
2

Verify the database is not full.

0
1

Just experienced the same issue and none of the above solutions have worked. It turned out to be some kind of corruption of content types. I had a specific content type (Document Set) added in to the library and that was my only one and default CT. I deleted default 'Document' content type from the library using browser. Then the issue appeared. I went to SP Designer and accessed setting for this particular library and deleted all the content types (except my default Document Set) from there. I deleted 'Document' and 'Folder' content types. The issue is gone now.

1

Sounds like this issue can be caused by a number of things. For my situation, I had added a calculated column (programmatically) to the site content type that was being used in my document library. There was a mistake in the columns formula that caused the problem.

1

I've just experienced the same issue... To solve it, I've deleted my columns one by one for the document library, until it unblocks things and it works again. In my case it was a dropdown/choice column.

1

In our case it was a bad default value we had programmatically set on a taxonomy field.

We weren't able to fix it by setting a good value (perhaps because we'd also corrupted the folder column default value). So we deleted and recreated the library without the bad default.

0

Researching your error message I found the following link from a user with the same issue, which appears to have resolved the problem for them -

Server error: The URL is invalid. It may refer to a nonexistent file or folder or refer to a valid file that is not in the current Web

However, I also found the following from Microsoft which provides a solution with regards to removing versioning on an indexed column.

https://support.microsoft.com/en-us/kb/2796640

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.