1

The search box in list view does not return newly created items.

But after sometime if you search it will show the item.

After creating the new item the item is visible on the list but if I try to search it using the listview search box it will not return.

Are there any settings to be enabled for the serachbox to show the newly added items when searched immediately after creating.

Content approval settings are not enabled.

  • When you say list view, is it a custom one or the one you see on allitems.aspx page? – Asad Refai Jun 18 '15 at 7:27
  • the one on allitems.aspx – Sabiha Jun 23 '15 at 10:53
1

The search box uses (as the name implies) the search engine, meaning that new files will not be returned before the search crawl has found them and added them to the search index.

In Office 365 the search runs all the time and quite rapidly finds new items.

You can if you like force a reindex of a document library from the library settings (but this will not speed up the time for new items to display when searching in the list search box)

  • Any workaround for the search functionality ?? I tried the connected webparts option, connecting a listview webpart to a text filter webpart, but it does not filter the content. – Sabiha Jun 23 '15 at 11:05
  • This is how it works @Sabiha. There may be tons of solutions that does the same thing, but your question is not about that, but why it is not working – Robert Lindgren Jun 23 '15 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.