2

We've got the following situation. Since today SharePoint central administration and the other 3 web applications are loaded as shown below. No Windows or SharePoint update has been installed since yesterday, where everything was working like a charm.

IE developer tools show no js files loaded for central administration. I'm sorry that it's in german, but I think you get the idea. It has been working for 4 years straight until today.

SharePoint Foundation 2010 SP2 has been installed on this machine. We've tried IE, Chrome and Firefox and all of them behave slightly different, but still with no javascript available. Trying to access the sites from an other machine -> same result. Configuration wizard has been running sucessful, there're no messages in the event log which would indicate a point of error. SharePoint logs are been written, although way fewer than normal. SharePoint Cache has been recreated, IE Browser Cache deleted with no change.

When I created a backup of a content database and restored it on an other server everything was working fine. SharePoint Designers shows the same error messages, when I try to open default.aspx.

I would really appreciate any suggestions, help or maybe even solutions.

enter image description here

1 Answer 1

2

If you access this from the server itself what happens? If you get a good page the problem is in the delivery (you may need to add your URL for loop back exemption before you can do this). you probably have a application firewall and/or proxy device between the workstation you are browsing from and the servers them selves, blocking the traffic.

If for some reason accessing the page from the server and get the same results there are some things you can try:

  1. Review the network trace - look for 404 responses and note the URL. If it is different than what you are using you probably need to update the Alternate Access Mappings.
  2. Ensure you are the site collection administrator (or higher) and access the page to verify it's not permissions. If you can see everything fine - than most likely some of the default library permissions on the site have been modified.
  3. On the server side - check that your upgrade was successful. Make sure all services and databases are at the correct patch level. it is not uncommon to find you have to re-run the upgrade via PSCONFIG.
  4. If you are getting access denied instead of 404 errors for files (again thru the network trace) in the _layouts folder than more than likely an update to group policy has locked you out. You can run Initialize-SPResourceSecurity to set the permission locally on the SharePoint server (if this is the case, you need to find out what/who changed the permission or it will most likely occur again).
3
  • I don't have access to the server right now, so I can't try out everything. I did run psconfig several times, I was site collection administrator, I didn't get any access denied messages, it simply didn't reply any js/css files. I've been trying to access the server directly and from an other machine, both with the same result. On the way home I thought about using Fiddler to see the network traffic between browser and IIS. Again .. the setting has been working for years and stopped just today.
    – Andreas
    Jun 17, 2015 at 19:52
  • 1
    That sounds more like a permission issue. Fiddler would tell you right away if you are getting access denied on server level resources (these would not result in an access denied in SharePoint for JS/CSS files). Jun 17, 2015 at 20:05
  • Hello Jesus, you were right about the permission issues. Somehow they changed over night (still no idea what happened there) and I found out that all images had unique permissions (to use sharepoint terms), so the apppool account couldn't access them anymore. I ran the Initializie command afterwards, so I can't tell if this would have helped immediately, but your answer defenitely points to the important things. Thanks again
    – Andreas
    Jun 18, 2015 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.