0

I'm trying to add lots of event to my calendar, so I'm using datasheet view of my calendar. But I found I can't copy-paste whole rows due to the recurrence column is read-only, and I can't hide it in modify view page as the checkbox of recurrence is grayed out. So my question is, how do I get rid of recurrence column in calendar datasheet view so I can copy-paste rows?

What I tried: I tried to go to SharePoint Designer > content type > event > and hide the recurrence column. It became hidden in event content type but still appears in my calendar.

  • Update: I have found a work around is to sort recurrence to the last column, and only copy the columns before recurrence. – SSilicon Jun 17 '15 at 15:44
0

You need to remove the field from the view in your browser. Go to your datasheet view, then click the List tab in the ribbon and select Modify View. Deselect Recurrance and click OK/Save.

  • The checkbox of recurrence is greyed out so I can't really deselect it. I wonder what's causing this? – SSilicon Jun 17 '15 at 15:42
0

Solution: Check the following to fix SharePoint list in datasheet view is read only:

  1. Content Approval must be turned OFF
  2. Some of the columns are dependent on the Microsoft Access, Check whether MS-Access is installed in client machine.
  3. Check whether you have permission to edit
  4. The document in the current row may be checked out by a user.
  5. Attachments are read-only in a list that requires content approval. You cannot view or edit attachments in any of the views.
  6. Certain columns, such as Created By and Modified, are always read-only.
  7. There may be an unresolved conflict or error in the selected row or column. Resolve the conflict or error before attempting to edit the selected row or column.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.