0

I am the owner of a site in which I have created sub-pages. I receive an error message with my correct user ID when I try to Edit the pages. I verified, multiple times, I have Full Control permission. I tried using the Designer and Style Resource Readers groups without success. Why is this happening and how can if be fixed?

  • Make sure that the pages are not checked out for editing by someone else. – Christoffer Jun 17 '15 at 14:04
  • Yes- I have ensured the page is checked-in and published. Thank you. – Julie Jun 17 '15 at 15:11
0

I had same issue. I simply had to provide global read access to the master page library. Site actions > site settings > Master Page and page layouts > Library tab > Permissions. Add All authenticated users to READ ONLY.

  • Interesting... I am also unable to view/edit the Master Page settings. I receive the same Access Denied error. – Julie Jun 17 '15 at 15:12
0

If the pages reference, even one item from somewhere where you don't have rights you will get access denied.

Run browser tools and start a network trace when you access the page. You should see all the requests being made for the page and resources. Review those and you should be able to see which element is being requested (and from where) that you can not load.

If it is the page library itself - try the following

  1. Attempt to access the list settings page. It's difficult via the browser as you need the GUID, but opening it up in SharePoint designer should work.
  2. If inheritance is broken - then change that to inherit site permissions. If it is not - then break it, remove permissions, and then inherit from the site again.
  3. You may need to have your account removed from the site collection and re-added - before that however I would....

Get more information from the server logs. the ULS logs will have a request for all SharePoint resources as well as any access denied messages and why. Your admins should be able to query and extract all request for your user account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.