We have a custom list that we are trying to edit in Datasheet view and are getting the following error when the next row is clicked:

Another user has changed the structure of this list. All your pending changes to this list will be discarded. To retrieve the latest copy of the list, click Refresh.

Obviously, clicking Refresh causes all changes to be discarded. Items can be entered by using the New Item form without issue. I have also verified that there are no calculated columns in the view and that the values we are trying to insert contain no commas. I have also verified that the choice columns do contain the values we are attempting to use.

Here is the structure of this list: List Columns

Here is the structure of the view: View Columns

Are we missing something obvious? Any suggestions would be greatly appreciated, thanks.

  • Can you give us the complete URL of the list? I had that issue with a list that had a special character in its name...
    – AlexPoint
    Jun 16, 2011 at 7:11

4 Answers 4


This might help: http://bmerri19.wordpress.com/2009/07/15/sharepoint-error-%E2%80%93-%E2%80%9Canother-user-has-changed-the-structure-of-this-list%E2%80%9D/

This is the content of the link:

SharePoint error – “Another user has changed the structure of this list” July 15, 2009 Recently while working on a recent SharePoint project, we ran into a problem when multiple users were editing a list item in the Datasheet view. We started seeing the following error below:

After searching online I found some solutions that recommended removing check-box columns from the view, however this did not work for me. I eventually opened up a case with Microsoft Services Premier Support (thanks Josh!) and we finally tracked this down to another column that contained a comma in the hyperlink URL (to a pdf drawing in another library):

http://sharepointserver/site/drawings/Colorado Springs,%20Colorado.pdf

Renamed the pdf drawing to not include the comma, added the updated hyperlink to the list item and no more error when editing other fields in a datasheet! This was pre SP2, so I don’t know if the issue still exists after installing SP2 or any cumulative rollups.

  • Unfortunately, I am unable to see that page due to corporate blocking. I am probably not the only one with this problem when it comes to Wordpress. Would you please edit your answer to include both the link and a summary of the solution presented? Thanks! Dec 22, 2011 at 13:33
  • hi, I added the text. Jan 10, 2012 at 14:30

I've seen this before where a title column, for example, is required but hidden in the datasheet view. In your case it looks like both of the required columns are exposed on the datasheet view, so I'm assuming you are entering them.

One thing you might consider is deselecting the columns one at a time from the datasheet view until it works. This will help you determine which column is causing the error and maybe give you a better idea what is going on.


I had the same issue. In my case it was a combination of 2 things...each which caused the issue. 1) A COMMA in the URL in a hyperlink field. Took out that URL (moved it to a non hyperlink field) and I was back in business. 2) A column that had column validation turned on, but that did NOT have that column in the datasheet view. Once I put the column in the datasheet view AND choose an appropriate value, all worked as intended. That was a tough one to crack!


For us it was some columns are indexed twice. So we created index for: Column A, Column B, Column A + B

By removing the third index we solved this issue.

Pretty hard to understand why Ms even allow the combination in this case.

  • This doesn't answer the question as per the Stack Exchange standards. Check How to Answer Feb 5, 2016 at 9:40
  • @Yash Saraiya, could you at least tell what is wrong with my answer? We indeed encountered the same error message on our SharePoint, but reason is due to double indexed column. I wrote it here in case someone else is having the same situation. So my question again, what is wrong with that?
    – Lin Jiang
    Mar 2, 2016 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.