0

When I run the following command:

$spapp = Get-SPServiceApplication -Name "Project Server Service"

Remove-SPServiceApplication $spapp -RemoveData

I get the following prompt:

Are you sure you want to perform this action? Performing operation "Remove-SPServiceApplication" on Target "PsiServiceApplication Name=Project Server Service". [Y] Yes [A] Yes to All [N] No [L] No to All [S] Suspend [?] Help (default is "Y"):

After typing "y" and pressing Enter it stays in a frozen state, where I cannot get out and also the deletion does not take place.

I have tried to delete the aforementioned service application through the GUI but it times out, thus the reason of using the powershell option.

Any pointers?

  • Have a look if the SharePoint timer service was stopped. Possible duplicate sharepoint.stackexchange.com/questions/5482/… – Dolgsthrasir Jun 17 '15 at 8:38
  • the SharePoint timer service was running, however when I open the project service application, I see the following message: WARNING: Project server provisioning timer job not found. – Luis Carvalho Jun 17 '15 at 8:56
  • Do you have more than one server, so that maybe the timer service has stopped only on one of them? – Dolgsthrasir Jun 17 '15 at 10:00
  • 1 server farm.. – Luis Carvalho Jun 17 '15 at 10:01
0

I would try to couple of things to deleted the Proj service App.

  1. Reboot the server and try again.
  2. Make Sure SharePoint timer job and Admin job is running.
  3. if their is any timer job missing, run the below command to provision all OOTB jobs.

    $farm = Get-SPFarm
    
    $farm.TimerService.EnsureDefaultJobs()
    
  4. I would also check the ULS logs and event Log during that time to get the root cause.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.