my problem is that when I try to edit a Wiki page with IE 9 on Windows 7 then the loading symbol appears in the right upper corner but it stays there and nothing happens. Also after waiting some time nothing happens. If I do the same in Firefox the Wikipage editor opens immediately and I can edit the page.

Does somebody know what I can do about this? Because our company mainly uses the new Internet Explorer this is very important for me...

Regards Manfred


When I enable the developer tools in IE I get the following java script errors:

SCRIPT5007: Für die Eigenschaft "style" kann kein Wert abgerufen werden: Das Objekt ist Null oder undefiniert core.js?rev=7rj7M86yP1%2BzonzuWjNsfg%3D%3D, Zeile 1 Zeichen 88542

english translation: for the property "style" no value can be obtained. The object is null or undefined.

SCRIPT5022: Sys.ScriptLoadFailedException: The script 'http://sbbintranet.sbb.it/_layouts/1033/init.js?rev=BjQJs0OCQh3Zfydsdw2MYw%3D%3D' contains multiple calls to Sys.Application.notifyScriptLoaded(). Only one is allowed. ScriptResource.axd?d=lDiNGjz4XOm281ALdA7LrvjdrkBrdlEspKL036xvOv38lW5imb69DaFjWS0_HEkNYIKVJ-rURaehhdJ6Y9QVQKcf9x03DUUjD1KxWYWQ-6Xc4OHm8O9HSXc7Vi93WbhyVYOASsdVZZBvoEnmM6L8DXe3eZm089hIuwFe-iLt_I18SmS20&t=fffffffff9d85fa6, Zeile 5 Zeichen 25340

  • maybe a JavaScript problem? Would it be THAT much of a problem to use Firefox instead? (You said yourself, it works there) My co-worker has problems with the IE9, too. I don't even want to use it. Commented Jun 15, 2011 at 14:22
  • 3
    if you have <meta http-equiv="X-UA-Compatible" content="IE=8"/> in master page, IE 9 should be able to render it in IE8 compatibility mode. Commented Jun 15, 2011 at 15:15
  • The problem is most likely some broken javascript.
    – bgmCoder
    Commented Feb 23, 2015 at 4:48

3 Answers 3


Perhaps you've already solved this and moved on, but since I ended up here when searching for a solution and didn't find it, I better add my solution:

A customer had exactly the same problem and the reason for it was that the customer is using a Language Pack (Swedish) on the site.

Solution: Go to the user menu (upper right corner) and switch to English. Now it's working!

The interesting thing is, if you now switch back to Swedish or whatever language you had, it still works (at least so far, it's been working for a week or so). I guess that it's some script file that gets cached from the English (correct) version that makes it continue to work.

  • I faced up the same problem, with Sharepoint 2010 SP1 and I had Italian laguage pack. This work around solved the problem also for me Damiano Cangi
    – user9719
    Commented Jul 27, 2012 at 15:06

The compatibility issues with SharePoint 2010 with Internet Explorer 9 were fixed with SharePoint 2010 Service Pack 1.

  • I installed the Service Pack 1 but still expiriencing the same problem. I also added the meta tag as suggested by Ashish but always the same problem. Is it possible that Internet Explorer does not support all features of sharepoint!? Commented Nov 18, 2011 at 7:36

Add the english-us language in internet explorer settings. It does not be have to be active

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.