0

I have a simple InfoPath 2013 Form. I have the Data Connection to the User Profile Service connecting and when I Preview my InfoPath Form it shows the correct Display Name of the user. However my InfoPath form is in a Web Part added to a page so that users can fill it out online through the web page. I simply need the Display Name of the user to display on the InfoPath form which is on the web page, however it is displaying the Service Account's information rather than the User name. I have attached Two Screenshots, one with the InfoPath Designer Preview (which displays my name Correctly) and the other in the Browser which does NOT display the correct name (Displays the User Account Information)

Does anyone have any feedback as to how I can fix this issue

enter image description here enter image description here

  • Is there information in Active Directory as far as a name is concerned? If so, a profile synchronization would remediate your issue. If not, it would be pulling the account name as the default display name. – Quinn Johns Jun 13 '15 at 0:45
  • Hello, Yes Active Directory has my name information stored, which appears when I open it up in InfoPath Client. However if I put the InfoPath form in a web part and add it to the web page, it brings up the service account name for some reason?? – Kam Jun 15 '15 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.