I am trying to browse a Sharepoint site in IE8 from the server where it is deployed.
When I am prompted to enter my credentials I enter them, but this doesn't work. The box keeps appearing and asks me for credentials.

It was working perfectly the last time I tried, but now I don't know what happened.

There is another user on the server and he can connect and browse without problems.
The operating system is Windows Server 2008 R2.

When I set automatic logon in IE8 I am not asked for credentials and I can browse the site with no problems. The problem is when I am asked for credentials I get stuck. I can't pass no matter what.

8 Answers 8

  • Check, or double check, if the loopback check is disabled
  • Check if you can log in from your client pc instead of logging in from the server
  • Disable "enhanced security" of the IE on the server (for test purposes only) and try it again
  • Add SharePoint site to the intranet zone in IE
  • Log in with "the other user" and check the permissions of your account (like it is done here: http://teamcollab.wordpress.com/2010/01/25/checking-permissions-in-sharepoint-2010/)
  • I disabled enhanced security of IE and i was able to enter the site. But when i choose to sign in with a different user (With enhanced security disabled) the same problem occurs. Please advise.
    – user3470
    Commented Jun 15, 2011 at 13:25
  • @Moussa: You still have not told us about the lookpback check, about adding the site to the intranet zone and if the issue persists if you log in from your client? Are you using NTLM or Kerberos?
    – AlexPoint
    Commented Jun 16, 2011 at 7:22
  • How can i know if i have NTLM or Kerberos?
    – user3470
    Commented Jun 16, 2011 at 8:10
  • I have edited the question. The site is in the intranet zone and i can't log in from a client.
    – user3470
    Commented Jun 16, 2011 at 8:43
  • It have been a long time since I run into this problem, now I can reproduce it by logging in using my account, select sign in with a different user and reselect my own account. I think this is what I was doing a year ago but these steps are a good starting point to fix authentication problems.
    – user3470
    Commented Jul 10, 2012 at 6:24
  • Go to IIS and select the corresponding web application
  • Here you should see Authentication: Click on it
  • On the right-hand side you should see Advanced Settings. Select it and see whether Kerberos is enabled or not.
  • If it isn't enabled, enable it by checking the tick box

I had this same issue, and I am not sure what I changed that caused this to happen. After I first installed SharePoint it was working, then after modifying a lot of things, it stopped working.

How I fixed this very frustrating issue.

  1. First I logged into the SharePoint server and ran the SharePoint 2013 Products Configuration Wizard.
  2. Next I went to Central Administration. Under Application Management click on Manage web applications.
  3. Highlight SharePoint - 80 and click on Application Providers from the ribbon menu. Click on Default.
  4. Scroll down to Integrated Windows Authentication and change the setting from Negotiate (Kerberos) to NTLM.
  5. Click on Save. Close this popup window.
  6. Next with SharePoint - 80 still selected click on User Policy. Add a user or edit the user in the list and set the proper permissions.

You probably don't have the local loopback check setup


  • Ryan i don't receive errors, the credential box keeps appearing it's like the credentials are wrong.
    – user3470
    Commented Jun 15, 2011 at 11:42
  • 1
    Asks for credentials 3 times then 401? Check it anyway 90%+ of the time this is the culprit.
    – Ryan
    Commented Jun 15, 2011 at 12:10
  • There is no 401 error just a blank page
    – user3470
    Commented Jun 15, 2011 at 12:27

My colleague at work has had this but from his laptop.I could log in each and every time. He could, then all of a sudden kept getting the prompt box returning as you describe. He could log in fine on the server but not from his Laptop. He could log in fine from my laptop too.

In the end we reinstalled IE8 as per a google find and the problem went away.

Just thought id mention incase anyone else is looking for this way around.



This could be a ton of different things, trust me I've had to track them all down at one point or another. When the Web application you're trying to access was created, what type of authentication was specified, Kerberos or NTLM? If it was Kerberos, were all of the service principal names created? In addition, for Kerberos to work correctly your DNS Servers need to have the correct host and reverse lookup records created.

If service principal names have been created, have the service accounts used to host the Web applications been trusted for delegation in the Active Directory domain? What is the domain operations and forest operations level? If this it's 2000 or 2003 you will have to add the service accounts to different built in groups.

What server operating system are the domain controllers installed on? If it is 2008 R2 and service pack one is NOT installed, but the SharePoint servers are 2008 or earlier then there will be a problem with encryption between the SharePoint servers and the domain controllers. If this is the case make sure you've fully patched the domain controllers.

Make sure the domain is in good health by running dcdiag. Ensure that all of the tests come back without issues. If problems are discovered you will have to correct them before moving forward.


In my case the web application was kerbros, I changed it to NTLM then problem solved.

  1. Log on on CA from IIS with localhost URL
  2. From application management -Manage web applications-press on web application
  3. From ribbon press on authentication provider
  4. IIS authentication part select NTLM

Sometimes it might happen due to change in permission level for a group you belongs to. For example changing your group permission from READ only to some Custom Permissions and that custom permission is not defined properly.

  • So just to check please go to site settings ->
  • Site Permission ->
  • Permission levels ->
  • click on your custom permission ->
  • see if 'List permission, Site permission and Personal permission' defined properly (in context of SharePoint Online).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.