0

I have the default document library in SP2013, I want to open documents inside that should open in a new tab;

I have selected Browser File Handling ->Permissive in central admin, now pdf file is opened in same tab and Office docs(Excel, word, ppt) are opened in client application.

  1. How to make Office docs(Excel, word, ppt) opens in the browser itself
  2. How to make PDF open in new tab instead of opening in same tab

Note: I want to do it in OOB or within SharePoint designer itself. Because the Entire site is made using these two only.

Thanks in advance

1

1.In SharePoint Central Administration, navigate to: Application Management > Manage Web Applications > [Web Application] > General Settings.

2.In the Browser File Handling section, choose Permissive. Users now have the option to open a file as well as save it.

0

To open the Office docs in browser itself: Go to Library setting--> Advanced Settings --> In section Opening Documents in the Browser, set Open in browser .

  • I did set Open in browser but still, it shows a popup to open in client application (Read or edit mode), Do I need to add any office add-on to my browser? – Gokul Jun 12 '15 at 10:14
0

I faced similar issue, my Excel documents opened in Client inspite of setting to open in browser. In my case problem was with the file format. The Excel file was saved as .xls, so we saved the file in .xlsx format and then it opened in browser.

0

This problem is most probably with ASP.NET Impersonation.

Solution:

Disable the ASP.NET Impersonation at the Server level and "SharePoint Web Services" level. Via: IIS > Authentication > ASP.NET Impersonation

https://support.microsoft.com/en-us/kb/2291790?wa=wsignin1.0

IF no ECS configured in the farm then check this

http://blog.armgasys.com/?p=133

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.